Thread: Discussion Fy-31ap
View Single Post
Old Sep 08, 2012, 06:22 AM
Integratedneck is offline
Find More Posts by Integratedneck
Registered User
Australia, QLD, Brisbane
Joined Aug 2012
80 Posts
Update

Today I spend the most part of the time out flying the Skywalker. I am almost certain I have found the cause of the problem of my Fy-31AP with its RTH and ACM mode. A summary:

Today I flew with 4 batteries. The conditions today were windy with quite strong gusts. I have all my PID settings set to default. The pots for the aileron gain set quite high. I reset the travel of my ailerons to their maximum. On the first flight the RTH and ACM functions worked every time. The plane came home and was not blown down wind. I tested it upwind, downwind, and making it have to fly across wind to home. Every time it worked very well, especially considering the conditions, it was fairly gusty at times.

Then for the second, third and fourth flights, RTH and ACM didn't really work. It entered its tight circling and never came home. Always getting further away and requiring me to take over. However, on the last battery of the day I noticed something important. I am using the hornet OSD. I notice the number of satellites would fluctuate quite a lot during the tight turns. It went from 11 down to 8 then when really bad 6 and even 5. Not sure if this was because of the tight banking. I then continued to watch. The information being displayed was inaccurate. It was like it had a significant delay. I flew the plane home and then flew it low and fast around me so I could monitor the information. I found the GPS to have a significant delay in its data. I would head north for about 100 to 150m and it would still say I was still heading south. The distance from home was wrong, it was also suffering from the same delay. Here is a link to this video (it even has a crash at the very end when another plane clipped the skywalker and knocked off the HD camera.)

A video showing a problem with the auto pilot with GPS lag. (12 min 26 sec)


Now at home I have reviewed the videos. The recording from the first flight differs from all the other flights. The GPS data is correct. When I head south, it reports I am going south. The distance is also correct. It also seems the update speed is much faster. This is the video of every time I try RTH or ACM it works.

So it seems there is a problem somewhere with my GPS. It gets a lot of satellites but the update speed to the OSD and I assume the FY-31AP is very slow. Perhaps there is some noise due to the wiring? So I know the system does work and very well. My problems donít seem to be control system related after all.

Also when reviewing the videos of when the GPS data is incorrect I see the update speed is too slow for the plane to make a decision to come home. Itís already turned away before it realises itís coming closer due to the GPS lag.

One thing to note is I did not change any settings on the FY-31AP today. Only thing that changed between the working and non-working times was the battery and a possible disruption to the wiring as a result of the two battery change outs.

Any Ideas? Seems I might not be far from solving my problems.
Integratedneck is offline Find More Posts by Integratedneck
Reply With Quote