View Single Post
Old Aug 26, 2012, 03:31 PM
mattchase is offline
Find More Posts by mattchase
Registered User
United States, TX, Seguin
Joined Mar 2005
611 Posts
Ok, I am now pretty much out of ideas and extremely desperate. I absolutely can not get the roll servo to stop twitching like a f*n maniac when I throttle up my motors. I have tried all of the following with no solid success:

- use an OpenPilot CC board as flight controller + gimbal (had some success with the gimbal, but copter didn't fly nearly as well as when the CC was acting as only a flight controller)
- use a Quadrino board as gimbal only
- tried MultiWii 1.9 and 2.1
- powered only the Quadrino board from separate battery
- powered only the roll servo from a separate battery
- wrapped roll servo wire around ferrite ring to isolate noise
- plugged roll servo into tilt axis and tilt servo into roll axis on Quadrino (roll servo still twitches, tilt doesn't)
- shoot self in head

The only thing I can think of that I haven't tried is to use a different servo on the roll axis because I don't have one that will fit. I have spent countless hours over the last couple of weeks trying different settings in both OpenPilot and MultiWii, the copter flies smooth without the roll servo activated, the gimbal operates fine when I am holding the copter and moving it around by hand, I even tried more jarring / shaking movements by hand and it doesn't cause any twitching. All of that with everything powered up EXCEPT the motors, as soon as I throttle up the roll servo goes nuts. So I think I have eliminated all but one thing...a defective servo?
mattchase is offline Find More Posts by mattchase
Reply With Quote