View Single Post
Old Aug 16, 2012, 03:04 PM
fishfiend is offline
Find More Posts by fishfiend
Registered User
Joined Jun 2008
485 Posts
Quote:
Originally Posted by winginman View Post
I took my V120D02S out of its carrying case, popped in a battery and the tail is out of control. It flew fine last time out...

I ordered a new tail servo and it came in today. Installed new servo and tried a test flight. No change still spins out of control. Servo seems to move slowly, but there is no binding anywhere in the tail. It all moves very freely. Tried resetting gyro and re-centering but it made no difference. Checked all transmitter settings and nothing has changed. It is as if the gyro has quit working.

Anyone experienced a similar problem or have any ideas. There may be something somewhere in this forum but I haven't had time to read through 400 posts...
Hold the tail rotor and slowly turn the main rotors ..don't hold too tight, there should be no slipping of the tail rotor as the main rotor turns..it sounds asif you've stripped a gear in the tail drive train. It's either the umbrella gear that's stripped, or the hole where the drive shaft fits has rounded out on the A or B gear, it could also be that the main shaft locking collar has slipped, sothe main gear is not engaging properly with the drive gear.. I've had all the above happen to me, ..oh and also the tail gyro sometimes doesn't engage, and the heli spins , re bind and it works again...... I love this heli! I just wish I could get it to Tic Toc!

Sorry guys my mother-in-law was ramblingon so it took me longer to type a reply!
fishfiend is offline Find More Posts by fishfiend
Last edited by fishfiend; Aug 16, 2012 at 03:06 PM. Reason: loads of answers whilst I was typing
Reply With Quote