View Single Post
Old Aug 16, 2012, 02:56 PM
BThirsk is offline
Find More Posts by BThirsk
Brent 黑雁
BThirsk's Avatar
Canada, AB, Ponoka
Joined Jan 2012
1,801 Posts
Quote:
Originally Posted by winginman View Post
I took my V120D02S out of its carrying case, popped in a battery and the tail is out of control. It flew fine last time out...

I ordered a new tail servo and it came in today. Installed new servo and tried a test flight. No change still spins out of control. Servo seems to move slowly, but there is no binding anywhere in the tail. It all moves very freely. Tried resetting gyro and re-centering but it made no difference. Checked all transmitter settings and nothing has changed. It is as if the gyro has quit working.

Anyone experienced a similar problem or have any ideas. There may be something somewhere in this forum but I haven't had time to read through 400 posts...
Any chance one of the tail drive gears are stripped out and the tail rotor won't get up to speed?
BThirsk is offline Find More Posts by BThirsk
Reply With Quote