View Single Post
Old Aug 14, 2012, 11:08 AM
nickelbn1 is offline
Find More Posts by nickelbn1
fly and then fly some more!
nickelbn1's Avatar
Springdale, AR
Joined Dec 2006
2,199 Posts
Quote:
Originally Posted by ICU View Post
Finally got thru all these pages....

I to am experiencing roll issues. Here's my setup

HS-65MG's all around
Omega 103
ZTW 50A esc
12x6 apc knock-off from hk

First day I flew I had to add just a few click of aile trim (forgot which way, and just chalked it up to maiden trimming). And yesterday was the second day I was able to fly it. I had some unwanted left roll, and I just thought that it was coming from the temp swings the plane went thru going from the office to the car to the field. Didn't think a whole lot about it cause I've experienced this with an epp profile I have. But after seeing other talk about it I'm all ears. I will reasses it after I fly tonight to see if I need to retrim the aile.

Now with a WOT blast mine will roll hard to the right, and the aile virtually do not respond. It's all I can do to keep it from rolling too far. But to be honest I can see why it's happening to me. One this motor has "stupid" power for this airplane, I actually think I'm going to pick up the 72 for this plane instead (it just feels like there is too much nose weight, not nose heavy, too much weight). Two I'm using a 12x6, so there's even more torque. And three these aile are made out of epp, they are going to flex and not keep their shape with the amount of force being applied to them with this motor prop combo.
Well yours is doing just like mine. It will roll hard right upon giving wot and like you its all i can do to get it back level giving full left aileron. It almost seems unresponsive. Except i am using the 72g and a apc 11x5.5. So i dont think your motor power is your issue. Or your prop. Something is wrong here......
nickelbn1 is offline Find More Posts by nickelbn1
Reply With Quote