View Single Post
Old Jul 22, 2012, 11:06 AM
David Canfield is offline
Find More Posts by David Canfield
Registered User
Toledo, OHIO
Joined May 2007
79 Posts
Thanks guys! I am the first person to look for true causes. I will say that in 7 years of sport and contest flying I have never had a radio issue that caused a loss of control of a model.

The tilting on the naza like it is out of trim is a recurring issue for me. I have tried to lift off in gps and it acts so out of trim that I can barely get it level. Or I can be hovering in manual or atti flip into gps and it will bank very hard to one direction, flip out of gps and it will level out. This does not happen all the time but enough to be a problem. I am going to remove the radio as a suspect on that issue. I also fly 700 electric helicopters and airplanes and I have never had random out of trim issue like this. Again it does not happen in manual or atti modes, every flight before gps was perfect.

My Wookong loss of throttle control is the one that concerns me. As stated other models were flown that day multiple times with no issue with throttle. Monitor screen was checked after crash with no sign of jumping or none working pot. I have never seen just one channel not work on a flight like that.

I will work to try and find the true causes, as I am not looking to blame any one device but more to insure this does not re-occure.

Tarro

i will check version, i do not think i am on the latest version, been some time since i have been in the assistant on my Wookong
David Canfield is offline Find More Posts by David Canfield
Last edited by David Canfield; Jul 22, 2012 at 11:29 AM.
Reply With Quote