View Single Post
Old Jul 18, 2012, 02:08 PM
7oneWo1f is offline
Find More Posts by 7oneWo1f
You will be assimilated
7oneWo1f's Avatar
United States, MN, Minneapolis
Joined Nov 2011
8,995 Posts
You may be able to remove some transistors, flash it with the right firmware, and then replace those transistors. But wait for junsi to let you know.

Quote:
Originally Posted by Gtaris View Post
Hi,

I wanted to use my new charger today but got a nasty surprise as it’s not working.
It reboots every 2-3 seconds and shows a message : “ERR: FLASH Memory”.

I flashed the firmware and tried the following ones : 3.12, 3.13, 3.14

3.14 : charger simply reboots with the error message and hangs (push buttons don’t work)
3.12,3.13: charger doesn’t reboot, the buttons and menu work, but when trying to start charging, after “Battery Check, Wait Please”, I get “ERR: FLASH Memory” again.

Diagnostic => DOA (Dead On Arrival) ???

As I bought it from HobbyKing, and already had top pay over 40euro's to customs for it + shipping costs. I would like to know if there's any other way to fix it ?
As an electronic engineer student, I think it's probably briked but still. I know the memory used for the firmware and memory settings work fine. So it's probably the 16Mbit logfile memory with is causing error but the problem could be elsewhere.
(I did only find one single post reporting this error)

Does anyone have any ideas or suggestions for me ?
7oneWo1f is offline Find More Posts by 7oneWo1f
Reply With Quote