Thread: New Product Official Eflite UMX Beast 3D
View Single Post
Old May 23, 2012, 04:48 AM
SilentPilot is offline
Find More Posts by SilentPilot
BMFA 190658
SilentPilot's Avatar
United Kingdom, Yeadon
Joined Mar 2007
5,776 Posts
Quote:
Originally Posted by RCBABBEL View Post
Tony,

Please keep us posted on how your 3S flights go.

Static WOT vs in flight WOT.
OCP kicking in??

AS3X doesn't like out of balance props, especially on 3S power!

rc
3S is a blast on the Sbach, guess I just got lucky...
Uses 3S TP250s (until the arrival of your Babbelbatts) 2300/5043 and is a lunatic!! It wont glide but who cares, I'll put a 2S 180 in to thermal it

The Beast 3D on the otherhand, well that run up nicely on a storage charged TP250 but when I took it to the local field with a full pack it seemed to hit OCP above 50% throttle (motor shutdown and flashing Rx until it reset). I swapped the motor back to OE and found a bunch of bad connections between ESC & motor. I've swapped back to 2300/5043 and fixed these then run pretty much a full pack through it static testing at 100% bursts, all seems good now.

I'm off back to the field now before work to test it for real. Might even take my Keyfob Camera to see if I can get some decent video, though last time I did that I got carried away and mashed up my Extra showing off. Maybe just some gentle circuits this time until I'm used to being on film

Tony
SilentPilot is offline Find More Posts by SilentPilot
RCG Plus Member
Last edited by SilentPilot; May 23, 2012 at 04:54 AM. Reason: Sorry guys, missed an entire page!
Reply With Quote