View Single Post
Old May 13, 2012, 10:40 PM
Scooter619 is offline
Find More Posts by Scooter619
Registered User
Joined Jan 2012
69 Posts
Help!
Turnigy Plush 25A for quadcopter won't calibrate with throttle in normal mode

I have a Futaba 10C radio (running a Spektrum DM8 2.4GHz module) and I've been having issues with my new build setup. I dismantled my VC-450 quad in order to move the Naza controller over to my new HT-FPV frame. I bought 4 new Plush 25A ESC's and 4 new Hoverthings 1050kV motors for this build. I couldn't get the ESC's to calibrate while plugged into the Naza, so I plugged each one in the the Rx throttle channel directly. Weird thing is, they don't recognize normal throttle stick input. So I switched the throttle to "reverse" in order to calibrate. Things seemed to be ok, until I plugged them back into the Naza. They won't spin after I initiate one of the Command Stick Functions. So I plugged the Naza into my computer and ran the "Tx calibration" function but because the throttle channel was reversed, the throttle slider in the Naza Assistant software moved opposite. So I reversed the throttle in the Naza Assistant so that the slider moved in the correct direction. I tried to restart the quad at this point, using a CSC, and still no go. I've tried switching out all the components (incl. Rx, Tx, Naza) except the motors and the ESC's, nothing helps. I used a ESC programming card and programmed these ESC's with the same settings that my VC-450 Turnigy 18A ESC's were programmed with. I figured that ESC's were pretty much plug-n-play. But these seem to be reversing the output somehow.
I could use some help from you guys with experience in this.

Thanks!
Scooter
Scooter619 is offline Find More Posts by Scooter619
Reply With Quote