View Single Post
Old Apr 15, 2012, 08:34 PM
salmans21 is online now
Find More Posts by salmans21
Registered User
United States, CT, Meriden
Joined Mar 2012
375 Posts
Hi guys, I am brand new to the forum and new to the f-86 sabre. I just received my sabre from towerhobbies on Friday along with the cable to use with my DX8 and 3 250 mah lipos. I was a little surprised when it didn't come with one of the 250 mah lipos like I had read on this forum. We had a perfect 70 degree day with very little wind here in Connecticut, so I decided to maiden the little jet today. As you can tell from the pictures I didn't get very far. I used the 250 mah lipo that tower recommended for the jet and placed it all the way forward like I read on this forum. I launched the jet into a very light 2-3mph wind while holding the throttle at about 80%.....and the jet basically went nose straight up to the sky (about 10 feet) and then came right down nose first. It seemed like the weight of the lipo just tore right through the nose of the jet. I repaired it and went back out a couple of hours later and the same exact thing happened except this time I had more damage (pictures are after the second crash). Any suggestions on what may be causing this (I made sure that all servos were moving in the proper direction)? Also do you think my shotty repair work is going to make the jet unflyable?? (I have a micro t-28 and brushless p-51...never crashed either of them). I am off tomorrow and will make another attempt this time with a camera recording so that if the same thing happens it may be easier to point out what I'm doing wrong.
salmans21 is online now Find More Posts by salmans21
Reply With Quote