View Single Post
Old Apr 07, 2012, 08:57 PM
AeroVideoUS is offline
Find More Posts by AeroVideoUS
aka Helidaho
AeroVideoUS's Avatar
United States, ID, Boise
Joined Jun 2010
3,014 Posts
I hate to say it but firmware 4 doesn't seem to work for me. I loaded it onto my green board with one switch and my gps board. It was a little breezy outside and it had a really hard time with the wind which isn't normal for my HFPro.

So I ran through the accelerometer calibration as well as the compass calibration and tried again. That's when I noticed flipping the AL switch didn't turn the HFPro LED blue. So I tried GPS and the led stayed green. All the while it was still having real difficulty with the wind. So I thought I would try the new ESC all at once calibration feature, zoiks! After I did that, the quad shook like crazy like I had the gains all the way up even though I lowered them almost to zero.

Still I hadn't made the connection that it was caused by the esc calibration I thought maybe I had some vibrations getting to the board so I took the boards out and while I had them out I used aluminum screws to put everything back together instead of the steel screws I had. Still wasn't flying well, doah!

So I loaded the highest 3.x version back onto the HFPro and GPS and it still performed terribly, shaking like crazy. This time I noticed the throttle response was terrible and decided to calibrate the escs again one by one on the Rx. With 3.x still loaded I went out and flew and everything was back to normal. Solid as a rock even with some breezes. AL, PH worked normally, led indicator worked normally and the camera gimbal responded normally.

So I decided to load 4.0 back on, the wind had gone so it was totally calm and it flew pretty well. Great I thought so I tried AL, no blue LED. Tried PH, nothing, RTH still nothing. I also noticed the camera gimbal, while really smooth now it was super slow and not keeping up with the quads movements. I tried flipping AL back and forth a few times and the led finally turned blue but when I turned it off the led stayed blue.

I know Ross in the 1st post mentioned he had a green board, I've got a green board, I wonder if this is only a problem with the green boards?

Sorry for the book, just trying to document everything I tried to get 4.0 to work.

Paul
AeroVideoUS is offline Find More Posts by AeroVideoUS
Reply With Quote