View Single Post
Old Mar 04, 2012, 08:56 AM
gbjbasdw is offline
Find More Posts by gbjbasdw
Registered User
Joined Dec 2010
48 Posts
So I tried charging the new battery again last night and the red "charge finished" light did come on but strangely it was not as bright as it normally is with the original battery and another identical one I purchased. This new battery I am trying is a 190mAh capacity so I odn't know if that would account for it or not.

Tried the heli again but it still rotates counter-clockwise. The trim and rudder control has little/no effect.

Another odd thing is that the rudder trim buttons don't seem to change pitch as I press them. All the other trim buttons increase/descrease in pitch as they are pressed.

I've also tried to throttle up with the rudder stick over to the right ( as per instructions on this thread ) without any effect.

I think it could be the motor going bad. I think I may have to resort to ordering some from China next week. Anyone know of a video/pictures that show how to change a motor over ?
gbjbasdw is offline Find More Posts by gbjbasdw
Reply With Quote