View Single Post
Old Feb 02, 2012, 12:26 AM
Parkflying is offline
Find More Posts by Parkflying
United States, MI, Auburn Hills
Joined Dec 2008
1,087 Posts
Quote:
Originally Posted by PRINCEY View Post
Hi Max

Did as you suggested but still no go. Servo operates o.k. when plugged in another point. Tried another servo in the elevator point but same problem. Only ok for forward flight movement no reverse movement.

Might it be the Receiver or Transmitter?

Strange one.
Looking at the original message, I am thinking you might have the servo arms out of position. are you flying in normal - low to high throttle stick mode or in "idle up" mode, where throttle is centered and pulling down inverts blades for inverted flying and pushing forward of center changes the pitch for normal lift?
I will check a correctly configured one on the bench tomorrow for precise positions.
Are you using a Skyartec Radio system? if so which model? Sky 701, 703, 705 or 706 ?
Parkflying is offline Find More Posts by Parkflying
Site Sponsor
Reply With Quote