View Single Post
Old Jan 25, 2012, 11:38 AM
Isoprop is offline
Find More Posts by Isoprop
Registered User
Joined Nov 2010
2,864 Posts
Possibly bricked #11 - Solid Yelllow LED which never blinks

Two of my older #11s now only show a steady Yellow LED when I turn them on. The Yellow LED does not blink and the shutter button doesn't react. I have tested the button with a multimeter and it is OK and the upper left leg does NOT touch the Microphone lead. The power button is also OK and does NOT make contact with the resistor on the bottom edge. Both crystals appear to be OK and not shorting.

I can flash different firmware versions, and have tried Release 1 (R1) and Release 2 (R2) in different flavors. With a freshly formatted card (SDFormatter), empty folders are created when I turn on the camera. Different names are created depending on the firmware version installed (R1 or R2) which proves the flash process worked. Also, if present, the date file is deleted from the card when I turn on the camera. The battery charges OK with both the "special" cable and the standard cable and the red LED indicates the charging process correctly. I have disconnected the battery many times. Reset switch also works (obviously!) but otherwise the camera doesn't react. No Webcam mode, no external drive mode, no recording - only a solid yellow LED when turned on. I've tried different cards but the yellow LED never blinks, not even when I turn on the cameras without a card inserted.

Searching this thread I found at least two postings with identical symptoms with more than two cameras being affected. Unfortunately short-clicking the power button and fastly-clicking the shutter button didn't work for me as it did for one reader.

I haven't a clue if this is hardware related or due to a wonky bit in non-volatile RAM, so I'm asking if anyone had the same problem and managed to get the camera working again.

As a last resort I will reflash the SPI, but that will involve first removing a good chip from a working camera. So I'll wait a bit on that... ... or does anyone have an SPI dump that is 100% working?
Isoprop is offline Find More Posts by Isoprop