View Single Post
Old Dec 30, 2011, 04:31 PM
wilco1967 is online now
Find More Posts by wilco1967
Registered User
Winterswijk, Netherlands
Joined Jun 2007
147 Posts
Quote:
Originally Posted by M4d_D View Post
hi there ...

i have a flydumini which doesnt want to fly ... it always flips when hovering ... i had to change the programming because the gyros dont work when its the correct way up , so i changed the props and it flies upside down but welll ... these sudden flips are weird ...

its built with turnigy 10A escs , 2000kv HK motors , original wm+ and bma020

can anyone help?
if not : does anyone want to buy it , i really dont have any fun with this thing , something like this never happened before , maybe someone else wants to try his / her luck
if so : please pm me :-)
Sounds like there is a orientation problem somewhere.....

The GUI symbol will move slowly, if the ACC data does not match the gyro and/or compass orientation.

If you can post a picture of your sensors, and check what you got in config.h (look for the part where it says :
//if you want to change to orientation of individual sensor
//#define ACC_ORIENTATION(X, Y, Z) {accADC[ROLL] = Y; accADC[PITCH] = -X; accADC[YAW] = Z;}
//#define GYRO_ORIENTATION(X, Y, Z) {gyroADC[ROLL] = -Y; gyroADC[PITCH] = X; gyroADC[YAW] = Z;}
//#define MAG_ORIENTATION(X, Y, Z) {magADC[ROLL] = X; magADC[PITCH] = Y; magADC[YAW] = Z;}
)
(or similar, right at the end).
wilco1967 is online now Find More Posts by wilco1967
Reply With Quote