View Single Post
Old Dec 30, 2011, 12:17 PM
Jessestr is offline
Find More Posts by Jessestr
Registered User
BelgiŽ, Vlaams Gewest, Evergem
Joined Nov 2011
738 Posts
Okay, I thought I found out what was wrong with the debug2.. Internal pullups wasn't enabled in the code. Because WM+ and BMA020 have internal pullups right ? (i dont know what it exactly does but I know they have).

So I uploaded it and armed the motors. It worked! v1.9 was alive on my quad. So I disconnected my USB cable, took my props, and put them on the quad. Connected the battery to the quad. And the arduino's led stayed on.. I2C error right? But how, everything worked?

Please.. What do I have to do.. Hope someone will finally help me..

Setup:
- Motors: Suppo 2012/13
- ESC: Suppo 25A
- Original WM+ as Gyroscope
- BMA020 as Accelerometer
- Flyduino Pro Mini (5V)

Internal Pullups, External.. ? I don't know what these are, I googled them but I didn't get any new understandable info about it. I'm a programmer, never learnt electronics so, I'm trying to find out what everything is. Please tell me what to do. I spent too much money on this thing to just let it stand here..

Thanks!
Jessestr is offline Find More Posts by Jessestr
Reply With Quote