View Single Post
Old Oct 24, 2011, 10:03 PM
Reef_rc is offline
Find More Posts by Reef_rc
Registered User
Reef_rc's Avatar
Joined May 2011
621 Posts
Gpmg4595

Quote:
Originally Posted by PittSpecial View Post
Reef_rc,

I did not see where you posted what type of Battery you were using.

What brand, capacity and most importantly Discharge rating?

Recall that I measured my buddy's Gerry (simano) the initial Tiger .10 motor which has identical 1250Kv. The AMP draw was close to 31-AMPs at wide open throttle.

I suspect that something to do with the ESC programming is to blame as the timing advance is not matching the motor. I do not believe Silver Series 35-AMP has automatic detection input impedance of the motor to allow for optimal Timing Advance of the RIMFIRE outrunner once you connect your Battery pack to the ESC. If this is the case then, your motor / esc and perhaps your battery are getting pretty hot because the operational setup on the ESC, especially at low throttle. A few years ago Castle Creations had an issue with the PHX-25 due to this problem and now all of their ESC's are Auto Detect for Motor input impedance and thereby, optimal timing advance.

http://manuals.hobbico.com/gpm/gpmm1...anual-v1_2.pdf

Call Mike at Hobby Services (217) 398-0007 Selection #5.

I have already briefed Mike and he saw this thread!
I am using:
  • Rimfire .10 (GPMG4595)
  • Great Planes Silver Series 35A Brushless ESC 5V/2A BEC - GPMM1830
  • 4 Servos - S3114
  • Receiver - Spektrum AR6210

I have the same setup on the GP Cosmic Wind.

Nice...I was just looking at the manual earlier this morning when I posted this. I had thought it might have been something I missed in the ESC setup (typically I just plug the darn thing in and go). I will try to call sometime this week as time permit (likely Friday). I didn't get any time today to do any research or testing the motor/esc.
Reef_rc is offline Find More Posts by Reef_rc
Reply With Quote