View Single Post
Old Oct 16, 2011, 05:06 PM
XDreamer is online now
Find More Posts by XDreamer
Registered User
Joined May 2010
117 Posts
I can't get the flashing to work! As I am a beginner in AVR programming it's probably my fault. I bought the usbasp (http://www.fundf.net/usbasp/) and built it successfully (?). When using avrdude or eXtreme burner I get the message "error connecting to chip".

I have double checked the pads on the RCTimer 18A ESC, and they are in the same order as on the Turnigy/Hobbywing 25A shown on the first page.

Some questions:
* Am I connecting the MISO/MOSI pins correctly? MISO ATmega8 - MISO Programmer, and MOSI ATmega8 - MOSI Programmer? Or should it be the other way around?
* Do I need to supply separate power to the ESC when programming? I have tried without power, with power from a LIPO, and with power supplied by the USB port. Same result - I cannot connect!

The driver is installed. The green LED is on when connected to the computer. The red LED flashes when running the avrdude commands. When specifying a lower speed the red LED flashes (visibly) for a longer period of time.

I'm grateful for any help you can give me!
XDreamer is online now Find More Posts by XDreamer
Reply With Quote