View Single Post
Old Sep 30, 2011, 05:01 PM
SeismicCWave is online now
Find More Posts by SeismicCWave
Registered User
Hawaii
Joined Feb 2003
5,986 Posts
Quote:
Originally Posted by Michael64 View Post
Putting some Turnigy Plush 30 ESC's on Avroto motors all run in correct direction but you have to move the stick about 18% and on one of them its about 25% before they start. The way I calibrated them was I put the throttle stick all the up pluged battery in got 2 beeps then 1 and moved the throttle stick to low and disconnected the battery with throttle trim at low as well. Programmed the the ESC with the card before calibrating in this manner I did this on the RC Timers and it worked but may not be right for the Turnigy Plush 30 ESC's does somebody have insight to whats going on this does not feel right with that much dead stick because they cut off at the some place. The revciever is a 9010X Spektrum and the 9303 converted to the DSM 2.4 module.
Any help would be great.

Michael64
Check the calibration again. If you are using MultiWii controller board you need to set throttle travel end points to 100% both high and low. Make sure throttle trim is centered and no sub trim

High throttle stick, plug in battery. ESC should go beep beep beep and then beep beep to confirm high stick. Then when you lower throttle stick you get one long beep if you have your battery type set to NiMH. If you set to LiPoly you will get more beeps then confirmed by beeps for the number of cells you are using.
SeismicCWave is online now Find More Posts by SeismicCWave
Reply With Quote