View Single Post
Old Sep 30, 2011, 04:52 AM
evgin is offline
Find More Posts by evgin
Registered User
Australia, NSW, Kellyville Ridge
Joined Mar 2010
31 Posts
Hi Everyone!

I've recently received my Blackboard with Navi and Ultra-sensor. And have build 2 copters:

X8 copter - based on 800Kv (10x4.5) 18A plush ESC

and X4 copter 950KV (10x4.5) 12A Plush ESC

And I'm having the same problem as others: GPS PH and RTH doesn't work. It keeps flying towards the north. I've tried to reset NAVI board, recalibrate GPS/M. During the whole week now, it does exact the same thing. As soon as I activate one of those options it flyes away from me to exact same direction.

I'm in Australia - I'm not sure if it somehow memorised it's home position in Korea and trying to get there :-)

But to be serious we need to sort this problem. It's really spoiling the whole experience!

After recalibrating it takes 30-45 sec. to lock GPS and gives me blue light.
Red light is solid. Copter performs very well, up until I use PH/RTH.

I've tried different positions for GPS sensor, ones installed it on shielded plate to eliminate interference, but result is always the same.

Please let me know if anyone managed to fix this problem!
evgin is offline Find More Posts by evgin
Reply With Quote