Thread: Discussion Powerlab 8 Parallel Charging
View Single Post
Old Sep 13, 2011, 02:57 PM
ldhflyguy is offline
Find More Posts by ldhflyguy
FlyGuy
ldhflyguy's Avatar
Batavia, IL, USA
Joined Oct 2007
383 Posts
Quote:
Originally Posted by Tim Marks View Post
Hi:

Here are some possibilities:

1) The batteries are not substantially discharged to a level that will allow Constant Current mode.

2) Your power supply is either not providing the power for which it is rated, or it is noisy. If available, connect 2 12v Lead Acid batteries in series and give that a try.

Tim Marks
Hey Tim,
Thanks for being my Hero!
I tried changing a few more settings via my laptop. Basically I tried uping the limits on settings that I thought could be the problem, but nothing seemed to help.

Your first sentence in your item #2 above got me to thinking. I remembered that when I first tested my new system, which includes a Mean Well 1500 W supply, that I had to lower the Supply Low Voltage Limit setting for my PL8 in order to get it to function correctly. TO SOLVE MY CURRENT PROBLEM, I FURTHER LOWERED THE Supply Low Voltage Limit from about 23.4 volts to 22.0 volts AND NOW EVERYTHING SEEMS TO WORK PERFECTLY.

Thanks again Tim. I hope others will benefit from what I've learned.
ldhflyguy is offline Find More Posts by ldhflyguy
Reply With Quote