View Single Post
Old Aug 31, 2011, 07:32 PM
Candu1 is offline
Find More Posts by Candu1
Registered User
Joined Jul 2011
280 Posts
Quote:
Since nothing I've so far seems to help, I then restored the sketch to the last working version - ie, pin9 active high and non-flashing. This seems to solved the problem. It has worked consistently for the last 5 power cycles.

Wondering if the issue has something to do with the flashing pin9 or is it just simply a bad sketch load the last time.
That was a premature concludion. When I tried it again with the ardrone on my work bench, it happened again. Nothing I was able to do to resolve it. Then I took it to my "computer room" so I can restore it to mirumod version .008. Just before I fired up my laptop, I gave version .009 another chance, I plug in the battery and it worked! again and again without a single startup failure. Now that was interesting...

I back step and return to my work bench, put the ardrone on the exact spot and plug in the battery. Yes, it failed to startup again! It was the first time I felt good about a failure!! Could it be the all metal work bench?? To confirm, I put a small cardboard box under the ardrone to raise it off the metal desk and try again. It started up OK. I repeat this quite a number times with and without the small box under the ardrone. Result were very consistent. I can repeat the results at well. Now it is obvious the metal bench is causing interference to the ardrone.

It is also interesting to note that the RC transmitter, was about 8 feet away on another table.

Wondering which component - the arduino, the RC rx, ardrone itself that prevents a proper start up. May be miru can tell by observing the arduino's flashing sequence.

I also did other controlled test with the tx 12 inches away from the ardrone in all directions and experienced no problems with the ardrone start up sequence. One test that did cause a failure is when I have the tx hanging from my neck and start the ardrone right next to the tx in front of me - a typical field battery changing scenario. Wondering if others can try this and report.

Here's a couple of picture of my test.

This position is where the ardrone fails to complete a start up:



Raise the ardrone 3 inches off the top of the bench, it works.



With the RC tx 12 inches away from the ardrone in all 4 directions would not cause any startup problems.



From the about tests, I am very confident to conclude that it is not a software issue. miru, you can sleep better now.
Candu1 is offline Find More Posts by Candu1
Reply With Quote