View Single Post
Old Jul 22, 2011, 03:39 AM
Old Man Mike is offline
Find More Posts by Old Man Mike
Registered User
Old Man Mike's Avatar
Joined Sep 2007
1,803 Posts
I received mine today and tried it with the V3 and standard OSD. I thought it would be a direct plug-in replacement for the previous altimeter but it required a firmware update of both the V3 and OSD. The V3 and OSD intially updated OK but during the OSD setup screen there was a "buffer overflow". After that the V3 would not recognize that the OSD was connected. I tried a second V3 and it would not recognize the OSD either.

I finally replaced the OSD and went back to the earlier firmware version and the older altimeter. I would like to be using the V4 Altimeter but I suspect there is something wrong with the latest firmware and I'm not going to risk another system that is working.

OMM
Old Man Mike is offline Find More Posts by Old Man Mike
Last edited by Old Man Mike; Jul 22, 2011 at 03:44 AM.
Reply With Quote