View Single Post
Old Jul 17, 2011, 09:42 AM
wheelspinner20 is offline
Find More Posts by wheelspinner20
Registered User
wheelspinner20's Avatar
S.E.Michigan
Joined Jul 2010
2,240 Posts
One of my #11 cams is dead.

Red light on usb hookup comes on... turns off when charged for a while.

No combination of any button pushes or resets or button/usb in out make the amber light come on.

I DID successfully use this cam about 10 times before this failure... functioned fine.

I did read first 3 posts and tried all but the re-solder vid processor chip.


I tried Gregsilvers "recover time" fix, even though my failure was not related to any firmware changes. It did not work.

I took apart case and inspected solders and tried cutting and resoldering battery ground wire for full power off reset.

One other clue is that these symptoms happened 1 week ago, and when I accidently dropped it on the table (short low impact) it worked good for 1 test recording and I then had to reset the current date and time again. Thought it would remain working but it did not.

Is my only option back to china? This purchase was back in may so I don't know if they will or can do anything.

Thanks for any constructive comments or suggestions.

(The other of the two is great and I love it.)

Pat
wheelspinner20 is offline Find More Posts by wheelspinner20