View Single Post
Old Jul 07, 2011, 12:30 PM
Kwazimoda is offline
Find More Posts by Kwazimoda
Registered User
Россия, город Москва, город Москва
Joined May 2011
12 Posts
Quote:
Originally Posted by Isoprop View Post
I wouldn't give up yet. If any firmware is installed correctly, the yellow light should turn on after you press the power button.

Make sure the card is empty, now SLOWLY try Tom's method here.

If that doesn't work, do all further testing without connecting the USB. There may be a difference when the battery is fully charged or only partially charged. Every now and again try and turn on the camera. Try this every hour or so. Also press the buttons for a minute or two together. Long-press the power button, etc. etc. I don't think it is good to press the buttons in quick succession though.

If you do this for more than about two days (a few attempts each day) and the camera still doesn't turn on, then I think you should contact your supplier and arrange for a replacement. But it may magically suddenly come back to life! Both of my cameras appeared bricked at first, but then came back to life and have worked perfectly ever since.

Also, try and put back a different V2 firmware, but use your card reader to do this.

I suggest you do all testing (except Tom's method) with the USB unplugged.

There may also be a "hidden" power-off timeout of approx. 2 minutes after the last key-press. This is just an assumption, though.
Thanks for no give up
So which steps I should repeat for 2 days? Attempts just to turn on the camera, or the full cycle?
Copy firmware file to card -> turn on-> wait for flashing complete -> turn off -> delete firmware file over card reader -> insert card -> turn on ???
Thanks.
Kwazimoda is offline Find More Posts by Kwazimoda