View Single Post
Old Apr 26, 2011, 02:39 AM
Isoprop is offline
Find More Posts by Isoprop
Registered User
Joined Nov 2010
2,864 Posts
Quote:
Originally Posted by Walkers View Post
....I've got a few questions:

* Has the "runaway clock" been confirmed as a hardware problem, or is the jury still out? I've tried all three firmwares (date on/date off/continuous recording) on my #11, and all three exhibit an accelerated clock. With the "date on" firmware I was able to watch the on-screen clock advance by ~90 seconds during a ~16-second clip. With the continuous recording firmware the only evidence I have is the timestamps on the movie and picture files. I took a few pictures in the office last night, all in the space of less than 30 seconds, and saw the timestamps advance by several minutes throughout. The camera currently has the continuous recording firmware on it.
....
In my case, I doubt if the "runaway clock" is due to an offspec crystal but rather some other offspec or shorted component. You may have different symptoms though. Like Tom says, this is still a mystery, and I would love to know what the cause is.

My clock ran EXACTLY 6 times too fast, which is the same as yours (~90 / ~16 = 6).
For short video clips (less than 5 minutes), my clock behaved as it should, and this is one of the reasons that I don't think it has anything to do with the two external crystals. However, once in "runaway mode" it stayed that way until the battery was completely depleted or disconnected. Changing the firmware didn't help.

My problem was completely solved by flashing the continuous recording firmware, BUT, I had to first flatten the battery completely for this to take effect, i.e. the date must revert back to 2009. If you don't want to disconnect the battery, use the time on or time off firmware and record as long as you can. Repeat this (turn on the camera and start over) for as long as you can turn the camera on. When you can't turn on the camera any more, the battery is, hopefully, depleted. Give it a 60 second charge and check if the file date is 2009. If the date has reverted back to 2009, fully charge the battery and only THEN use the continuous firmware.

You can't use the continuous firmware to deplete the battery because this firmware stops recording long before the battery is flat. Well, I suppose you could, but it would just take you much longer turning the camera on/off and recording. Pressing all possible buttons at the same time and for a minute or so may also help, but I don't recommend this method if the camera works otherwise...

If you attempt the above, please keep us informed.

The "runaway clock" is, IMO, a good reason for a replacement - or you may be able to negotiate a cheaper second camera. I found it most annoying when the file date and time stamp was completely incorrect.
Isoprop is offline Find More Posts by Isoprop
Last edited by Isoprop; Apr 26, 2011 at 03:32 AM.