View Single Post
Old Apr 15, 2011, 04:03 AM
aeajr is offline
Find More Posts by aeajr
Proud member of LISF and ESL
LI, New York, USA
Joined Mar 2003
25,334 Posts
Quote:
Originally Posted by mikeht View Post
maiden the RP today...

It's been a while since I've flown so I warmed up with the T-28, a plane that I'm familiar with. It was a little windy, but the pz T-28 is a very honest flying plane. So after the first battery, and a decent landing, all looked good.
Time to get the RP in the air. By this time the afternoon breeze had turned gusty, but confidence was solid. Radio checked the RP, rechecked the flying surfaces, tested the thrust and gave it a shove into the wind... Boy did I have a handful, something's wrong! Under throttle the nose pointed straight up, then backing off the throttle the nose would fall past the horizon needing back elevator. If the plane would have been painted blue, it would have looked like Flipper on a happy day. Plus the plane had a hard time banking right. First of all I'm guessing I have the CG too far forward because the battery is way out of the pocket, even though this is where it balanced for the 70mm. As far as the slow roll rate I'm think I'm going to redo the aileron linkage, and wait for a calmer day in order to trim it out.

I'll go back through the posts, because I remember reading something about this plane and porpoising, plus I'll try balancing at 77mm like some of you guys have suggested. What else am I missing.

thanks, Mike
You have some kind of set-up problem as I have not heard of these kinds of problems with the pro.
aeajr is offline Find More Posts by aeajr
Reply With Quote