View Single Post
Old Mar 16, 2009, 08:57 PM
Rotor13B is offline
Find More Posts by Rotor13B
Registered User
Colorado
Joined Jan 2007
423 Posts
Quote:
Originally Posted by ThrakenSal
Yeah when I got the plane 2 weeks ago I tried charging the batt on the supplied charger and my good charger too. Both said there was an issue with the battery, and hobbico concurred as they replaced it. The new one I received today charged right up on the supplied charger, and my good charger just balanced it a bit before it was done. I used my voltmeter and all the voltage looks good. So I turned on the TX and put the battery into the plane and connected it up. I heard one beep, should have been two. The servos all started chattering and the lighting system came on. I tried the aliron and elevator functions on the TX and nothing happened. I tried the rudder and again nothing happened. So I took the prop off and tried the throttle, and again nothing. I don't have a 4.3 RX pack but I do have an old AA cell pack that I will try out on it to see if it might be the ESC but since the TX has a rattle to it, I think it might be busted. I'm going to send it off to Hobbico to see if they can find the issue, but I'm not sure if they will honor the warranty now that I've had the plane for two weeks and counting. And of course, everyone knows the Tactic Radio system that comes with this thing is pretty much junk.
Mine only beeps once also but everything works fine. I would try a different pair of crystals if you have some/ borrow some. If you have another receiver or can borrow one that would help figure it out pretty quick.
Rotor13B is offline Find More Posts by Rotor13B
Reply With Quote