View Single Post
Old Mar 16, 2009, 06:48 PM
ThrakenSal is offline
Find More Posts by ThrakenSal
Registered User
Granbury, Texas
Joined Feb 2009
55 Posts
Quote:
Originally Posted by yarsmythejr
Sal,

Let's go back to square one and try to figure this out. You said you replaced the motor battery but how did you confirm the battery was bad? Would it not charge with the included charger? Second, when the new battery arrived did it work on existing charger? Are you able to check the voltage on this new battery?

"Chattering" from your servos usually means it can not get a signal from your transmitter. This can be from dead TX batteries, a loose TX antenna, poor location or broken receiver antenna, loose crystal on the receiver, or a bad servo.

Here's is my suggestion. Pull the receiver out (if it can be removed easily) and plug in a 4.8/6v receiver battery directly into it. If you don't have one, take everything to your LHS and ask if you can borrow one. Plug in ONE servo to the receiver and turn on your transmitter. Try using the transmitter to run the servo in each channel. If this works then you have hopefully ruled out the expensive pieces (receiver / transmitter). Next you will want to plug in the ESC/BEC into channel 3, plug in your LiPo (no motor necessary) and see if the speed controller is providing enough power. If this works, then we might want to check the servos in the plane. I've had a bad servo that caused all kinds of problems with my receiver. Swapping it out did the trick.

Start with basic parts and then add one at a time. That's the best way to troubleshoot this problem. From what you've said...my guess would be an antenna (RX or TX) issue or a bad cable connection.

Let us know.

-Lee
Yeah when I got the plane 2 weeks ago I tried charging the batt on the supplied charger and my good charger too. Both said there was an issue with the battery, and hobbico concurred as they replaced it. The new one I received today charged right up on the supplied charger, and my good charger just balanced it a bit before it was done. I used my voltmeter and all the voltage looks good. So I turned on the TX and put the battery into the plane and connected it up. I heard one beep, should have been two. The servos all started chattering and the lighting system came on. I tried the aliron and elevator functions on the TX and nothing happened. I tried the rudder and again nothing happened. So I took the prop off and tried the throttle, and again nothing. I don't have a 4.3 RX pack but I do have an old AA cell pack that I will try out on it to see if it might be the ESC but since the TX has a rattle to it, I think it might be busted. I'm going to send it off to Hobbico to see if they can find the issue, but I'm not sure if they will honor the warranty now that I've had the plane for two weeks and counting. And of course, everyone knows the Tactic Radio system that comes with this thing is pretty much junk.
ThrakenSal is offline Find More Posts by ThrakenSal
Reply With Quote