RC Groups

RC Groups
    Power Systems
        55 dollars brushless with speed control! SAVE YOUR MONEY..

#1 Basil Jan 15, 2005 10:17 PM

55 dollars brushless with speed control problems..
 
Thought I would bring this up in the Power Forums...

My LHS had the combo for 52$ so I could not resist...Got home and installed it right away..Not sure if this is normal, however, when 1st starting out, it hesitates for a bit, then kicks in fine...Also, at full thorottle i hear some hesitation/strange noises, but when I back off to 75-50% it runs smooth..
What could this be?

***********************
Standard 8x4 GWS DD prop with LHS 3mm prop adapter...

Today in a test flight after i spent a good 30 secs trying to get the motor started, (Everyone at my field was giving me crap about buying such a chep Setup) Finally started and took off. I throttled down in flight to about 10% or so and then gave it full throttle and the motor sound like a record stratching i cut throttle to 0% then i tired to restart and couldnt get the Inuenndo Removed thing started again...Luckily I had plenty of field to drop out of the sky...FYI

Fresh 3 cell right off the charger...Tried a different pack and same proplem with and with out the stupid jumper on. Very Unhappy...

I have to have a bad motor, My motor ,if it ever spins, pulsates at full throttle, however, it stops at about 50% or so...at this rate, I should of stuck with my IPSA

#2 xoon Jan 15, 2005 11:14 PM

that got to sux... $50 of nothing

#3 ryanl2006 Jan 15, 2005 11:55 PM

Do you have any other brushless motors and/or brushless esc's? I only ask because I am curious as to whether the problem is the motor, the esc, or both?

#4 NoM'rcrashPlease Jan 16, 2005 01:57 AM

are you using the combo, like the one that Balsapr is selling???

This setup?

#5 Ecaf Jan 16, 2005 09:10 AM

Quote:

Originally Posted by Basil
TURNS OUT THIS IS HAPPENING ALL OVER!!!

Who else is having problems?

If this setup is the BP21 from BalsaPR, I dont have a problem at all with the motor or the ESC.
I have used the 2 combined on a 10oz 3D Foamie. Worked great with 3 cells (TP 1320 G2). The ESC itself works great with Ryans Double CDR motor and I have run the BP21 motor with a CC10. No problems at all.

I didnt experience any of the issues you listed above.

Have you tried different ESC's with the motor?

TB

#6 gunfighter Jan 16, 2005 10:21 AM

HMMM... I've got 3 of the BP-21 / 18A ESC combo's from Balsaproducts and have not had a second of trouble from any of them. They are a little louder than other brushless set-ups but they operate well. :confused:

#7 Thatovalguy Jan 16, 2005 11:48 AM

http://www.rcgroups.com/forums/showt...44#post3177044

#8 Basil Jan 16, 2005 01:44 PM

well if everyone's is working, then i must be in the minority...ill take the proper steps off line to resolving this issue

#9 Fred Bronk Jan 16, 2005 03:54 PM

Basil, is this your setup? Sounds like it is.

Can't help if you don't tell us.

#10 Foam Crazy Jan 16, 2005 05:57 PM

hey basil,
i know the frustration. even a mighty company like castle creations sometimes put out a dud. one of the phoenix-25 brushless esc's i bought stuttered and sputtered and did not work nicely at all. awesome customer service and replaced it with a brand new one in 3 days flat.

don't lose heart about bargain shopping for electronics. we all do it, with mixed results. there are bound to be a dud in a good batch, and a gem in a bad batch.

seeing as it is from a local store, i'm sure they'll work with you on this purchase. good luck and see you out there.

-james

#11 sa-10 Jan 16, 2005 07:26 PM

Basil, what volt/ma batts are you using?

#12 Ben Lanterman Jan 16, 2005 07:38 PM

The jumper pretty well describes the same systems even if different names are put on them.

I have 3 and all work fine. Good price for something that is going to hit nose first if I make a mistake.

#13 Basil Jan 18, 2005 11:52 PM

Hate to double post but the main thread is over in the Foamies which I havent figured out why it hasnt been moved here yet, but anyway, turns out Im making some progress, but still not there..

http://www.rcgroups.com/forums/showt...42#post3190442

I didnt want to make any more of this, but do to all the PMS I received, I thought I should keep a progess report.

#14 Basil Jan 19, 2005 07:50 AM

Ok We Have A Winner!!!! Works Great!!!!

#15 taekwondo Jan 19, 2005 09:21 AM

I don't understand why you didn't return it to the LHS?


All times are GMT -5. The time now is 04:42 AM.