RC Groups

RC Groups
    Power Systems
        Discussion ESC not working

#1 electricpic Feb 10, 2013 08:48 PM

ESC not working
 
Hi folks,

I think that one of my turnigy esc plush 25A is not working.
The esc is new, i only tested it once and it worked fine, but now i don't get any beeps from the motor it is connected to and i have 0 volts on the bec (in my other esc i have 5V).

I've tested it with other motors and the problem persists (the motors are all ok).
I've also checked all the connections and they seem to be ok (i'm using bullet connectors).

The low voltage cutoff function of this esc is activated for 3.3v or less but i'm using a fully charged 3S battery (~ 12.4 volts).

Any ideas of what is going on?

#2 hoppy Feb 10, 2013 09:29 PM

Disconnect leads to motor and try again without them connected. Same result?

#3 abenn Feb 11, 2013 02:57 AM

If your voltage measurement is correct, either your BEC is not working, or it's connection to the receiver is bad (or your ESC doesn't have a BEC). If that's the case, your receiver is not getting any power, so the ESC can't initialise and make its beeps -- and your servos won't be working either.

If you've got a standard NiMh receiver battery, you could power your receiver using that, and see if the ESC works then. To be sure it's not the throttle channel on the receiver that's faulty, using the receiver battery, plug any servo into the throttle channel and see if it responds to throttle stick movement.

#4 electricpic Feb 13, 2013 04:48 PM

I've figured out that the problem was on the gnd connection.
I recheck all the connections again and in the process of doing it sometimes i had a voltage signal sometimes i only had 0 volts.
It turned out to be just a not well soldered bullet connector.
I just had to solder the connector again.

Thanks for your help anyway.


All times are GMT -5. The time now is 11:14 AM.