RC Groups

RC Groups
    Batteries and Chargers
        Discussion Turnigy nano-tech A-SPEC 2200mah 3S 65~130C Lipo Pack

#1 beachflyer Feb 01, 2013 05:34 PM

Turnigy nano-tech A-SPEC 2200mah 3S 65~130C Lipo Pack
 
1 Attachment(s)
Has anyone tryed some of theseTurnigy nano-tech A-SPEC 2200mah 3S 65~130C Lipo Packs? Cost me 30 bucks a piece.
I ordered two thinking it would be nice to have some high amp threecells.
Well two arrived in mail today. Fast shipping from HobbyKing USA.
I checked votage and one cell on one pack was 3.70volts and the others were 3.80.
So I charged up and ran on low amp Heli that never pulls over 15 amps. Well after a couple of minutes heli last power quick and after checking voltage the one low cell was down a volt from the other two.
Anyone else having issues with this brand?
Thanks
John

#2 mrforsyth Feb 01, 2013 06:01 PM

What charger did you use and did you verify with a meter that all cells were actually fully charged prior to testing in your heli?

#3 beachflyer Feb 01, 2013 06:38 PM

Yes I verified. Been flying Electrics for over 25 years and know whats going on. Just wondering if others are having issues. I always balance charge all my lipos. ALWAYS

#4 beachflyer Feb 01, 2013 06:42 PM

I have Balance lead volt meters I use before and after every flight and charge cycle to keep tabs on them. I have over 50 planes and helicpoters with 100's of lipos. So I babysit them. I have math and engineering background and understand the chemestry process fully.

#5 rcalldaylong Feb 01, 2013 06:45 PM

well these lipos haven't been out too long so probably not too much input on them. I sorta shyed away from HK's nano altogether because of this issue...and was hoping to hear better results on these 'A' brand.

You said you bought 2 paks...How's the other one doing?

#6 KCinNC Feb 01, 2013 06:45 PM

i had a lipo that acted like that once, it was not a nano-tech, i put it on charge at only 1amp and let it sloooow charge. took a while but that seemed to balance it out

#7 rcalldaylong Feb 01, 2013 06:55 PM

Quote:

Originally Posted by KCinNC (Post 24005383)
i had a lipo that acted like that once, it was not a nano-tech, i put it on charge at only 1amp and let it sloooow charge. took a while but that seemed to balance it out

Well, yes it balances out; but the problem is when you put the Lipo under load, the 1 cell craps out and drops voltage (aka voltage sag). These Lipos become bricks and make nice door stoppers after a while...and I mean no more than 5-10 flights.

#8 mrforsyth Feb 01, 2013 07:10 PM

Quote:

Originally Posted by beachflyer (Post 24005322)
Yes I verified. Been flying Electrics for over 25 years and no whats going on. Just wondering if others are having issues. I always balance charge all my lipos. ALWAYS

Definitely sounds as though you're on top of it and simply got a bum pack. :(

I'd request an RMA and send it back.

http://www.rcgroups.com/forums/showthread.php?t=1659178

Mark

#9 beachflyer Feb 01, 2013 09:22 PM

Quote:

Originally Posted by mrforsyth (Post 24005594)
Definitely sounds as though you're on top of it and simply got a bum pack. :(

I'd request an RMA and send it back.

http://www.rcgroups.com/forums/showthread.php?t=1659178

Mark

Mark I have already dont that. I charged up the bad cell and then balanced them and the bad cell crapped out again so its going back I hope.
Thanks
John

#10 beachflyer Feb 01, 2013 09:25 PM

The other cell is working good but I will be keeping close watch on it. I have had issues with nanos the last couple of years and will no longer be using them. I used to have real good luck with the 30c Rhinos back in the day

#11 mrforsyth Feb 01, 2013 09:43 PM

Hope it all works out well for you John.

I know what you mean about the 30C Rhinos. I have several 2S1050mAh 30C Rhinos that I bought several years ago and they're incredible. One of my buddies bought a bunch of 3S and 4S 2250's about 4 years ago and they have also been fantastic with IR of ~4 mOhm per cell when new. He recently bought some additional Rhinos of the same specification and they were garbage right out of the chute with IR of 12-15 mOhm per cell. His older and well-used packs are still around 7-8 mOhm per cell.

It's strange that vendors are passing off garbage now that modelers have a lot more information and better tools to assess performance than a few years ago. That's why we need to keep them honest. :)

Appreciate you sharing your experience!

Mark

#12 hoggdoc Feb 02, 2013 05:19 AM

Quote:

Originally Posted by beachflyer (Post 24005356)
I have Balance lead volt meters I use before and after every flight and charge cycle to keep tabs on them. I have over 50 planes and helicpoters with 100's of lipos. So I babysit them. I have math and engineering background and understand the chemestry process fully.

And yet you can't spell "no whats going on" really, or "tryed". Come on guys use your spell and grammar checker. :o

#13 goldsworthy Feb 02, 2013 05:22 AM

I think he just got 1 defective pack. I have many NANOs and have had no trouble with any of my packs

#14 jmolwitz Feb 02, 2013 07:54 AM

I bought 4 packs of 6s 4000 mah nanos 25-50's All the packs had balance issues and one pack had a dead cell:( I still get my packs from HK but as a rule I consider a 25% failure rate common . I have to laugh HK says they check every pack before it goes out :rolleyes:

#15 Dr Kiwi Feb 02, 2013 12:12 PM

Quote:

Originally Posted by hoggdoc (Post 24009035)
And yet you can't spell "no whats going on" really, or "tryed". Come on guys use your spell and grammar checker. :o


"chemestry" and "helicpoters" are unusual variants of the King's English too.


All times are GMT -5. The time now is 12:02 AM.