RC Groups

RC Groups
    Beginner Training Area (Aircraft-Electric)
        Help! Aileron servo and lipo problems. Need help!

#1 kennyhoc3 Nov 26, 2012 04:39 PM

Aileron servo and lipo problems. Need help!
 
*Update* Figured out one of the servos was going past center making it roll the opposite direction.

#2 600Bob Nov 27, 2012 02:05 PM

Kind of sounds like your servos are not returning to center, or something in the linkage that causes the control surfaces to to center thus they are a little out of trim each time you change directions.

The battery may be old and not up to the task. The motor may be over propped and pulling too many amps. LVC of 3.8 seems high, you generally will fly down to that voltage or even a little lower and still have 20% capacity remaining plus the voltage under load can drop below that then recover during flight.

Do you have a computer Lipo charger? How much current goes back into the battery when recharging after a flight?

#3 kennyhoc3 Nov 27, 2012 05:43 PM

Yeah its weird, I re-centered the servo linkages manually, then I decided to put the ailerons on separate channels to setup flaperons so I can land in my front yard haha but they still like to roll the opposite direction when I level out =( I tried another plane with the same settings and it flew fine. So I think its something with the plane or possibly RX?

I flew a quick easy flight testing out the setup, 4min 35seconds and the charger put 591mah back into the battery. It was toasty warm compared to the cold weather outside no puffing this time haha. Yeah the LVC does seem kind of high, when I land the lipo's usually at 3.6v-3.8v per cell, should they be discharged lower then that?

#4 kennyhoc3 Nov 27, 2012 06:02 PM

Battery times seem about right though, If I read the specs right this motor can pull up to 40A. So with this lipo I could run full throttle (40A) for about 4 min. I have read that the slight puffing after use is fine as long as it goes back down. But if it stays puffed from say overcharging/discharging its toast.

This motor, prop size and esc are what I have read multiple people using in 3d planes about the same as this. although this plane is a little heavier then others with the full fuse and larger battery.

#5 acetech09 Nov 27, 2012 06:12 PM

Landing at 3.8v idle is the safest you could do, most likely. Any lower and you're in the danger zone in most instances.

The fact that you're only putting 561mAh back into the battery suggests that there's something seriously wrong. I think the cold is to blame. Do you warm up your LiPos in your pocket or in the car before using or do they go into the plane cold? LiPos really don't like to be cold.

It also might be a dead cell, but let's hold off that avenue since cold seems the most likely suspect until proven otherwise.

If it isn't the cold, I'd still suggest getting some higher-C batteries. Your nano-techs are almost certainly over-rated by HK, as HK does to most of their batteries... I'd suggest finding batteries that can take your load without puffing or getting hot at all... even temporary puffing is bad for the packs.


In response to your ailerons: The cold might be getting to them. Some cheaper servos don't handle cold well. Sounds like the issue is bad centering if the plane wants to roll after moving it back to center. It is most likely the servos.

#6 kennyhoc3 Nov 27, 2012 08:25 PM

Yeah I always keep my lipo's at room temp, if they are going to be out in the cold for a little while I normally warm them up a little before I put them in my pocket or in the plane. I flew once more before the sun went down this time I flew untill the LVC tripped. I flew about 7min and spent 1200mah. I think that sounds about normal?

Yeah maybe the cold is getting to the servo's. But it seems weird that they would go past center and roll the opposite direction. I could see them being cold and not going far enough haha but that's just my luck =( I would be the one to have the weird issue not many have seen lol

#7 flypaper 2 Nov 28, 2012 06:35 AM

On some planes the wings innertia will cause it to roll a little further. Takes that much to get it to stop. Technique is to let the ails. go to neutral before the turn is completed. Find the right spot and it will stop when level every time. Every plane is different in this respect.
As to your puffing batt, what does the motor amps show with a wattmeter??Higher ma rated batt might help too, if it will fit. Gives 2 pluses, cooler batt. and longer run time. As said above, higher C rating will help too.

Gord.

#8 kennyhoc3 Nov 28, 2012 11:14 AM

That sounds like it makes sense! Being a bigger plane & rolling fast haha I will try and stop it earlier :)
I haven't checked it with a wattmeter yet but if my run time calculations are correct it would be about 20A-25A average. Yeah there is lots of room in so I will have to try a higher rated battery!

#9 acetech09 Nov 28, 2012 11:18 AM

Ah - I remember that you're used to micros. I assumed you would have factored out plane inertia when descrbing your servo issue, but if this is your first non-micro plane, it will be different. Does it constantly slow down a bit after centering the stick, or is it a definite servo-induced roll that would eventually barrel roll the plane if you didn't do anything?

#10 kennyhoc3 Nov 28, 2012 08:11 PM

Yeah I am pretty sure it will continue to barrel roll 360degrees until I correct it. I have only let it go about 90degrees before I roll the other way to cancel it out. Its veryyy noticeable and I don't think there would be thatttt much inertia. I was going to try and get a video of it today but my AXN came today so I built that.

My luck got the best of me though...It always does! What should have taken 1-2hours took me almost 7hrs to build this PNP AXN. I bought a 45a turnigy esc and I could not get it programmed at all with 2 of my turnigy receivers. Everytime I turned it on it would go into programming mode and not respond to anything (I think the guy I bought my TX/rx's from messed something up big time, because one of the lifepo cells ends up draining in 10min when used normally). So I switched on the dsm module(lifepo works fine this way) and tried with my DSM rx from the edge540 and it armed and worked like a charm, I still haven't programmed it though (and I don't really want anything to get messed up lol).

I finally got the plane built and ready to fly and of course the sun just set so it was too dark to see lol I left the dsm RX in my and tried the turnigy 8chv2 receiver and the esc went into programming mode, So I unplugged the lipo and replugged it back in, This time the motor was twitching and the servo's were as well so I unplugged the lipo and I smelt something burning =( I double checked all the connections and nothing was mixed up. Lipo/esc have xt60's on them so I didn't mess that up. I took the dsm rx out of the axn put it in the edge and the motor armed like normal but was very quiet. When I gave it a bit of throttle it was very underpowered. So I am guessing it got fried somehow....Could a bad receiver cause this?

Long story short I hate my luck. Nothing goes my way. Even when I stick to micro's random stuff happens...My old P-51's battery wire jammed the elevator servo as soon as I completed a stall turn and plummeted nose first into the ground!

I realize its my luck that makes me change hobbies so often lol I get tired of it xD

#11 kennyhoc3 Nov 28, 2012 09:35 PM

I talked to a local guy and he told me of the motor resistence test touching the wires together (unplugged of course) So I did that and the motor passed So I took the ESC out and plugged it all in like normal and the esc started smoking...Guess the esc went out on me =(


All times are GMT -5. The time now is 10:18 AM.