RC Groups

RC Groups
    Hoverfly Technologies
        Help! Fried my Hoverfly pro!

#1 FPVlarsen Sep 27, 2012 05:29 AM

Fried my Hoverfly pro!
 
Hi,

Due to my esc got hot using the internal bec for the hoverflyboard i connected power from my osd to the esc input. I was sure the output from osd was 5v, but it was lipo voltage 14,2v!
So when i connected the battery it smoked!!
It also fried my reciever!

Anyway, i connected the board to another reciever and updated the firmware again. The update process works fine and the led is green.
The problem is that only two of the esc output works.
(I tried the esc/motor direct on the reciever and they all work)

Is there anyway to fix this?
I really like the hoverfly pro, so I hope there is a way to repair it?

Roald

#2 photronix Sep 27, 2012 09:04 PM

Unfortunately the level converter chip on the ESC outputs is most likely damaged.

You would need to replace the 20 pin SMD IC near the ESC port. Not an easy job unless you have an SMD desolder system.

Do you have the Yellow Jacket Protection plan? Because you could send us the board and we would send you a new one.

http://www.shop.hoverflytech.com/Yel...JACK-00011.htm

#3 FPVlarsen Sep 28, 2012 02:08 AM

1 Attachment(s)
Yes it looks like the chip is broken.i took a photo of it to see the description, but I cant find it anywhere.
I dont have the yellowjacket, but I will try solder it.
Could you send me a new chip or a link to where I could buy?

Roald

#4 S11D336B Sep 28, 2012 12:15 PM

If you haven't already, open a support ticket and I can help you find this part.

Quote:

Originally Posted by FPVlarsen (Post 22855505)
Yes it looks like the chip is broken.i took a photo of it to see the description, but I cant find it anywhere.
I dont have the yellowjacket, but I will try solder it.
Could you send me a new chip or a link to where I could buy?

Roald



All times are GMT -5. The time now is 08:53 PM.