RC Groups

RC Groups
    Multirotor Electronics
        Discussion Motor won't spin, can't find the problem, please read and help

#1 Troiano27 Jul 17, 2012 07:29 PM

Motor won't spin, can't find the problem, please read and help
 
Ok, got my f550 up and flying. While hovering back and forth, I would notice a sudden dip to one side ever few seconds or so. I was only a few feet off the ground, when I noticed one of the props stopped spinning, and the craft became unstable, and slid into a hard landing. Upon inspection it looked as one of the motor to esc connections may have been loose, but none were unconnected. I pushed them all back in as best as possible, and tried it again. 

This time however my number 2 motor wouldnt spin (only will spin like a 1/4 turn every few seconds or so).  I posted on the forums, and it was suggested my solder connection might be bad. 

When I made it home tonight, I took things apart, resoldered my connection, put back together and tried again. No luck, same thing happening. I have a spare motor and esc, so I first swapped the motor out, same thing happening. So then I unsoldered the esc, and chanced that, still no luck. 

So thinking it might be the Naza, I swapped the connections for motors 1 & 2, same thing happen on same motor. 

My only conclusion is it could be a bad power distribution board.  Does that sound like a possibility? 

Any other ideas?

Thanks for the help,
Jeff

#2 shultz Jul 17, 2012 09:34 PM

If I understand right you now have the first ESC/motor setup that would not work as your spare? If so, solder a deans or what ever type of battery connector you use to that ESC and solder up the motor, hook the ESC directly to the throttle CH on your receiver(unhook everything else but the BEC) now, without a prop of course plug in your battery and see if the motor spins up... If it does then you know the problem must be at the Power distro...thats if you're sure the solder joints are good;)

It really sounds like a bad motor>ESC connection or bad phase... with the spare setup doing exactly the same thing it almost has to be a power connection issue or bad distro trace.


All times are GMT -5. The time now is 08:34 PM.