RC Groups

RC Groups
    Batteries and Chargers
        Discussion icharger 306b help - was Dell 2850 power supply help

#1 Terkan Jul 01, 2012 05:13 PM

icharger 306b help - was Dell 2850 power supply help
 
After trying over and over to figure out what is going on with this thing it occurred to me that I could try to power it from one of my 6S lipos to eliminate the power supply as the culprit (don't know why it took so long to figure that out..). I had previously just assumed it was the power supply since 12v worked fine but running of 24v I would get the intermittent resets. The 306b resets the same running off of a battery once it ramps up to between 14 and 18 amps. I'm trying to charge an 8Ah 6S pack at 30 amps. The charger has the latest 3.14 firmware and I reinstalled the firmware without change.

Anyone seen this before or have any suggestions?

Thanks!


------------------previously posted:---------------------------------------------------------------
I have two of the power supplies as pictured here:
http://www.rcgroups.com/forums/showp...&postcount=408

I followed the schematics on RCGroups get them powered up, isolate the ground and use a voltage divider for fan speed control.

They work exceptionally well! -usually.

I run them in series with a 306B charger. Intermittently, and I can't find a pattern, they will reset once the charger ramps up to about 14 amps. Once this happens powering them down/unplugging/whatever doesn't seem to restore (but they'll work fine in series up to 14amps). Next time I try to use them in series they'll work fine at 30amps. Doesn't matter which order I connect them and while this is happening each independently will happily provide my charger current up to its 12v limit (~21amps).

Any ideas?

#2 Terkan Jul 06, 2012 01:51 PM

Updated with new info.

#3 TheWoodCrafter Jul 06, 2012 09:02 PM

What do you mean they "reset"?

They shut off?

Have you taken any voltage measurements?

#4 Terkan Jul 06, 2012 09:05 PM

The 306b resets. It flickers then reboots. It does this from the 24v power supply's or from a 25v Lipo source. It is intermittent and sometimes works fine.

It always works flawless on a 12v source.

#5 TheWoodCrafter Jul 06, 2012 09:12 PM

What do you have Input Limits set to?

#6 Terkan Jul 06, 2012 09:20 PM

50amp

#7 TheWoodCrafter Jul 06, 2012 09:23 PM

No.

In the charger under settings it has a place to set the voltage input limits.
One is the max and one is the min.

What do you have them set to?

#8 Terkan Jul 06, 2012 09:26 PM

Should be defaults but I just checked and input max is set to 50, min to 4.5. I could have sworn when I changed the 50 with the right arrow it went to 1a and then I put it back to 50.

The resets on 24v are intermittent as well, sometimes works fine

#9 Terkan Jul 11, 2012 01:15 PM

Thanks to very friendly people at EPBuddy, ProgressiveRC and Junsi we've determined it was a defective unit.

Thanks for everyone's help.


All times are GMT -5. The time now is 08:10 AM.