RC Groups

RC Groups
    Beginner Training Area (Aircraft-Electric)
        Help! Binding Issues Super Cub DSM

#1 PatrickRC Apr 20, 2012 06:49 AM

Binding Issues Super Cub DSM
 
I bought a new receiver/esc for my Hobbyzone Super Cub DSM and I followed the binding instructions but once its bound and the light on the receiver is solid red (this means its ready). None of the controls work and they are all plugged in the right way. What might be the issue here? Any idea helps!

#2 dedStik Apr 20, 2012 07:16 AM

Are you sure they are all plugged in the right way? Is the RX you installed compatible with your transmitter?

#3 Rayne Apr 20, 2012 09:52 AM

Did you remember to take out the bind plug, unplug the battery, turn off the radio, turn the radio back on then plug in the battery?

Did the LED's on your transmitter flash indicating it was in bind mode (assuming you had a DX4e)?

Did the receiver's LED blink very rapidly during the bind process then slow?

Was the radio at least a couple feet away from the receiver (having it too close can sometimes cause problems)?

Was the lipo battery fully charged up and are the radio's batteries not dead?

Short of that I'd go back and carefully read through the instructions again to make sure you're not missing something.

#4 marklind Apr 20, 2012 11:53 AM

I just had the same problem with my new Cub this morning. I either only get a blinking red light (not bound), or if I get a solid red light, the servos don't react well. I went through the process step-by-step many times. I tried binding it to my dx6i, and it worked perfectly the first time. Any thoughts on what it could be?

#5 PatrickRC Apr 20, 2012 02:50 PM

All of the batteries are either new or fully charged and it is the stock receiver with the stock transmitter a dx4e.

#6 PatrickRC Apr 20, 2012 02:51 PM

The binding process that was stated is exactly what i did and nothing happened.

#7 Rayne Apr 20, 2012 03:21 PM

Well then if the transmitter wasn't too close to receiver when you bound it then I'd say give horizon a call.

#8 marklind Apr 20, 2012 04:03 PM

-Rayne- I was having a simialr problem (see post above). I just tried binding with the transmitter farther away (6 feet), and it bound with no problems. Give it a try.

#9 Rayne Apr 20, 2012 04:09 PM

Quote:

Originally Posted by marklind (Post 21388946)
-Rayne- I was having a simialr problem (see post above). I just tried binding with the transmitter farther away (6 feet), and it bound with no problems. Give it a try.

Great to hear it, it's unfortunate that they don't always mention this in the instructions. This problem pops up a bit from time to time.

#10 PatrickRC Apr 20, 2012 04:18 PM

Thanks for the info I will try that. Marklind was your light solid red and not flashing when you were having troubles. Did any of your servos work or throttle?

#11 PatrickRC Apr 20, 2012 04:24 PM

Once I bound it from about 6ft away I heard the servos move. But now my elevator servos is making a noise like it is struggling to move. The servo is doing this only with the transmitter on. Either of the servos or throttle still dont respond to any transmitter action.

#12 Rayne Apr 20, 2012 04:42 PM

What happened to the last brick (receiver/esc/servo) you had for your super cub?

Have you flown with the DX4e before and how did that go?

Did you install the new brick inside your plane yet or are you testing it outside first?

#13 PatrickRC Apr 20, 2012 04:48 PM

I have had the plane since christmas and I have flown with the dx4e the whole time. I try and fly every weekend. The old receiver/esc that came with the plane got wet when i was flying it over the lake at my cabin with floats.

#14 Rayne Apr 20, 2012 04:53 PM

Your motor and servos may have been damaged as well by the water. Did you let everything dry out for a few days before trying them? Unplug everything from the receiver/esc then go through the bind procedure just with that. Then connect each component one at a time and test to see what works and what doesn't.

#15 PatrickRC Apr 20, 2012 05:23 PM

I bound it again without anything connected to them. When i plugged the servos in nothing happened. But when either one is plugged into the elevator port in the receiver no matter which servo it is it still makes a struggling sound. The motor doesnt work connected to the receiver but i connected it straight to the battery for a split second and it spun right up. I am very appreciative of your help so far too.


All times are GMT -5. The time now is 01:43 AM.