RC Groups

RC Groups
    Multirotor Talk
        Help! KKmulticopter v4.7 won't start

#1 dsiee Feb 29, 2012 12:09 AM

KKmulticopter v4.7 won't start
 
3 Attachment(s)
Hi all!

so i've finished my first quad build (as in put everything together) but i can't get the HK KK board to start! so everything is plugged in right and i can control the motors/program the ESC's by putting the yaw pot to zero, but i can't do anything else.

So all pots are at 50% and everything is plugged in but when i power the board up i only get one flash of the LED not the 3 that i should get according to this guide and tried t=flashing the board with the 2.0 firmware that the manual is for.

i have am flashing the board with the KKmulticopter flash tool on OSX using the USBasp from hobbyking.

Build is using-
DT700, Mystry Blue series 20A, HK KK Flight controler, Mode 1 HK 2.4ghz 6ch tx/rx

any help and/or resources is greatly appreciated!

* photos of setup as atacments

#2 sg1anubis Feb 29, 2012 12:49 AM

Check that your transmitter and reciever are properly bound. Once the battery is connected you must army the board by applying full right yaw at zero throttle. If the led does not light in response to arming then you may need to adjust the trim and end points of your radio so that it recognizes that the throttle channel has a pulse between 1000-1100 micro seconds and the rudder between 1900-2000. It could also be that your channels have been reversed or the connections between your kk board and the reciever are incorrect.

Another thing I noticed is that you state you are using a mode 1 transmitter, therefore, the arming procedure may be different than the standard mode 2 transmitter.

#3 dsiee Feb 29, 2012 01:55 AM

Thanks, I've just rechecked connections from receiver to the flight controler and redid the t6config for the HK controller.

This helped because I did manage to arm it ONCE! However I haven't been able to do it again and I have know idea why. It's frustrating when things don't work at all but it's even worse when they work some of the time :(.

So any pore suggestions? The ESC's make their little startup sound however they don't respond to the throttle.

I personally thing it has something to do with the fact that the led on the HK kk board doesn't flash 3 times.

#4 samwei1950 Feb 29, 2012 10:10 AM

Maybe a help,my experience......
1.may needed to change a RX
2.change the thrust connector(single line connector) to conventional connector
(3 lines connector) of the board,so two conventional connector(thrust & rudder)
and two single connector(aileron & elevator) on the board
get rid of props before any try for safty reason
good luck
Sam

#5 Tres Wright Feb 29, 2012 12:55 PM

Quote:

Originally Posted by dsiee (Post 20891625)
This helped because I did manage to arm it ONCE! However I haven't been able to do it again and I have know idea why.

Sounds like the first time I tried to start up a KK board. Remove your props if you haven't already. Set your endpoints to 125% and make sure your dual rates (especially yaw since that's what arms it) are at least 100%. Turn on your TX and try to arm the board. If it doesn't arm, unplug it, reverse your throttle channel, power it up and try to arm it again. Once you get it to arm then you can play with reducing EPA and dual rates, if it quits arming then set them back up again. I originally had mine set up with 100% EPA and 70% dual rates on yaw and it would not arm. It was frustrating trying to figure out what was wrong.


All times are GMT -5. The time now is 08:11 PM.