RC Groups

RC Groups
    Skyartec
        Discussion Skyartech Ninja 400 tail rotor problem

#1 antboy6969 Feb 04, 2012 05:14 AM

Skyartech Ninja 400 tail rotor problem
 
hey guys recently i have been having some problens with my ninja 400 . the tail keeps jittering too much probably the gyro set too high but when i had a look at the gyro the gain was turned to less than half way? is it something wronge with my tx (sky 706) ? and i also notice when i am hovering and i quickly put the throttle all the way up it goes up realy fast but the tail keeps moving left. that only happens when i give the heli bout 90% throttle quick , is that normal or is their something wrong with the belt?
sorry for my bad english
any help will be helpfull.
thankyou so much for your time.
ps my tx is loaded up with the mode 2 default ninja 400 profile.

#2 Parkflying Feb 05, 2012 12:17 AM

Quote:

Originally Posted by antboy6969 (Post 20636311)
hey guys recently i have been having some problens with my ninja 400 . the tail keeps jittering too much probably the gyro set too high but when i had a look at the gyro the gain was turned to less than half way? is it something wronge with my tx (sky 706) ? and i also notice when i am hovering and i quickly put the throttle all the way up it goes up realy fast but the tail keeps moving left. that only happens when i give the heli bout 90% throttle quick , is that normal or is their something wrong with the belt?
sorry for my bad english
any help will be helpfull.
thankyou so much for your time.
ps my tx is loaded up with the mode 2 default ninja 400 profile.

Do not change the gyro setting on the gyro unit. change the sensitivity in the software settings of the transmitter, using the configuration software. Maybe reduce the setting only a few percent at a time. Also insure you do not have any broken or worn down teeth on the main gear. make sure tail belt is very taut, like a stretched out rubber band.

Let us know if any of this helps

Max


All times are GMT -5. The time now is 06:03 PM.