RC Groups

RC Groups
    Multirotor Talk
        Discussion Alternative MK Flight Control FC v1.33 - v2.0 MK THREAD-PART2

#1 bob.titus Feb 09, 2011 08:46 PM

Alternative MK Flight Control FC v1.33 - v2.0 MK THREAD-PART2
 
__________________________________________________ __________________________________________________ _______________________________________


since "Alternative MK Flight Control FC v1.33 - v2.0 MK THREAD" has been closed by Quad Addict, here is "Part 2" to follow up...
Part 1 is here : http://www.rcgroups.com/forums/showthread.php?t=1300414


Important notice :

you are buying and using a clone MK at your own risk, and I'm not promoting nor selling anything here and cannot be held responsible for your choice.

I simply opened this thread to continue what was started and closed by Quad Addict and because I know many people rely on this, including those using the real Mc Coy ;)

I don't believe the clone is detrimental to Mikrokopter.de but on the contrary contributes to it's development.
Those who buy this cheaper copy wouldn't buy the original one in the first place, and I know for a fact that most will naturally go to the original product after a short while (Quad Addict did and so did I as an example).

__________________________________________________ __________________________________________________ _______________________________________

Now back to the thread :

G and Dan, do you know how to flash the Ublox with v4 firmware, I couldn't find how?

Cheers,
Bob

#2 G-unit Feb 09, 2011 09:01 PM

Cool, i will send info..

#3 hexa Feb 09, 2011 11:27 PM

too bad the part 1 is closed there was tones of good info in there.

#4 dt8666 Feb 10, 2011 12:53 AM

Quote:

Originally Posted by bob.titus (Post 17363185)
G and Dan, do you know how to flash the Ublox with v4 firmware, I couldn't find how?

Cheers,
Bob

Hi Bob,
Not tried loading other firmware yet but should be a simple one.

For the config file loading as you can read from the Wiki (I know too much reading....), you have to do the followings:
- download the ucentre software from ublox site
- download the xx2008xx.txt file from the wiki site - under GPS
- run the ucentre and connect the GPS module with USB
- look for the selection of loading of config (i think is under tool as I dont have my hobby NB with me now) and load the file. try this as if you still have issue, I will forward you the full instruction (or maybe someone can also forward that to you since I did send that to someone else here)
- after finish the above (you should not see a pink screen if all goes as normal), click on view and look for Configuration, click the port and select UART1, 0+1 binary NEMEA, 57600. and click send at the bottom screen. then select configuration and click send once.

DONE! you should read the Sat info reading from MKtool after you reconnect all back as usual! If your GPS module is working.

Hope this helps.

#5 hawaiitaco Feb 10, 2011 03:25 AM

subbed.... sucks the other thread had to close....... anyways... did a real low hover with my i2c converter....looked like it worked...more mktools setting adjustment and probably do a maiden flight sometime soon.....looking good...

#6 MalaysianFlyer Feb 10, 2011 05:49 AM

Just to make sure we dont loose track of part 1

http://www.rcgroups.com/forums/showthread.php?t=1300414

#7 bob.titus Feb 10, 2011 06:03 AM

Quote:

Originally Posted by MalaysianFlyer (Post 17365885)
Just to make sure we dont loose track of part 1

http://www.rcgroups.com/forums/showthread.php?t=1300414

good thinking, I've edited my first post.

Bob

#8 milouze Feb 10, 2011 06:09 AM

subscribed too..:)

#9 n3m1s1s Feb 10, 2011 06:43 AM

i havnt bought one yet still working out which motors are best for me so im glad theres a part 2 aswell :)

#10 Quad_Addict Feb 10, 2011 06:46 AM

Quote:

Originally Posted by bob.titus (Post 17363185)
since "Alternative MK Flight Control FC v1.33 - v2.0 MK THREAD" was getting too big and has been closed, here is "Part 2" to follow up...
Part 1 is here : http://www.rcgroups.com/forums/showthread.php?t=1300414

G and Dan, do you know how to flash the Ublox with v4 firmware, I couldn't find how?

Cheers,
Bob

no shame eh bob? you wrote it was closed because it was getting to big? WRONG, YOUR one of the reasons it was closed, so kinda funny you make another thread with the same name eh? more and more people will learn about you, you want to live in my shadow, be my guest.

#11 dt8666 Feb 10, 2011 06:46 AM

1 Attachment(s)
bob... here you go for the GPS picture

#12 Chukmil Feb 10, 2011 07:52 AM

Quote:

Originally Posted by hawaiitaco (Post 17365431)
subbed.... sucks the other thread had to close....... anyways... did a real low hover with my i2c converter....looked like it worked...more mktools setting adjustment and probably do a maiden flight sometime soon.....looking good...

Thats great, I will be interested in the settings adjustments you make

#13 bob.titus Feb 10, 2011 08:24 AM

Quote:

Originally Posted by Quad_Addict (Post 17366139)
no shame eh bob? you wrote it was closed because it was getting to big? WRONG, YOUR one of the reasons it was closed, so kinda funny you make another thread with the same name eh? more and more people will learn about you, you want to live in my shadow, be my guest.

funny enough I was just trying to be fair with you, but never mind.
And I'm one of the reasons?? Because I was trying to get my gps working and asked for help on "your" thread?
What's wrong with some of you guys on RCG?
Don't worry, people will learn all about me soon enough, with ot without your "help".
There are a few things in the pipeline I cannot discuss now but later ;)

Anyway it's working now, thanks to G and Dan... and a bit of luck I guess.
By the way, somebody mentionned gps was supposed to be flashed with v4 firmware, mine is loaded with v5 and seems to be working fine.


Bob

#14 bob.titus Feb 10, 2011 08:38 AM

Quote:

Originally Posted by dt8666 (Post 17366141)
bob... here you go for the GPS picture

thanks Daniel,
this confirms I didn't screw up bridging 5v with first capacitor next to it ;)
All is fine now, I believe battery was dead and something happened because of it.
I left the GPS connected to USB on the PC all night and all seems ok now.
I have replaced the faulty ME 2.2 with a genuine ME 2.1 and will test later today.

Bob

#15 noppita Feb 10, 2011 11:07 AM

1 Attachment(s)
ok part2, so i will do my first post with question

anyone has flash this green bl with 0.42 or other version before, i have red bl and know how to flash red bl with red mkusb , but when i tried green bl with red mkusb, i can not flash it, it give me something like can not reset


All times are GMT -5. The time now is 08:28 AM.