RC Groups

RC Groups
    Micro Helis
        Discussion 4G6 ESC getting too hot?

#1 Dan203 Aug 23, 2010 05:45 PM

4G6 ESC getting too hot?
 
A few weeks ago the motor went out in my 4#6S. Instead of buying a new stock one for it I took the black TurboAce out of my 4G6 and then bought an HP07-2 for it. After installing it I discovered it had a bad cogging issue. I did some reading and found that they recommend using the ESC from a CB100, instead of the stock one, when using this motor. I happened to have an extra CB100 ESC lying around so I threw it in there. The cogging went away so I thought all was good.

However now I think the ESC might be getting too hot. I've only flown it maybe a 1/2 dozen times since putting in the new motor, but I just noticed that the clear plastic around the ESC has shrunk so much that it actually split at one of the corners and the yellow plastic sleeve around the RX is rippled slightly on the side the ESC is stuck to. It doesn't feel hot to the touch, even right after a flight, but the signs point to it getting pretty hot during flight.

Is this normal? Is it something I should worry about?

Dan

#2 Tom Z Aug 23, 2010 08:18 PM

Quote:

Originally Posted by Dan203 (Post 15866464)
A few weeks ago the motor went out in my 4#6S. Instead of buying a new stock one for it I took the black TurboAce out of my 4G6 and then bought an HP07-2 for it. After installing it I discovered it had a bad cogging issue. I did some reading and found that they recommend using the ESC from a CB100, instead of the stock one, when using this motor. I happened to have an extra CB100 ESC lying around so I threw it in there. The cogging went away so I thought all was good.

However now I think the ESC might be getting too hot. I've only flown it maybe a 1/2 dozen times since putting in the new motor, but I just noticed that the clear plastic around the ESC has shrunk so much that it actually split at one of the corners and the yellow plastic sleeve around the RX is rippled slightly on the side the ESC is stuck to. It doesn't feel hot to the touch, even right after a flight, but the signs point to it getting pretty hot during flight.

Is this normal? Is it something I should worry about?

Dan


Sounds normal.
My esc ran HOT also. It shrunk the heat shrink on the esc like yours is doing.
It is the L2 CB100 esc.
It's best to remove the heat shrink from the esc and it will run cooler. Don't mount it
directly to the RX. It will melt the yellow heat shrink housing as I found out.

The HP07-2 motor is an amp hog and will make you esc run hot.
My canopy was even very warm due to the heat from the HP07-2 and esc.
Not to mention the battery was very warm and the battery connector
was hot.
The motor and esc combo produces a lot of heat but runs fine.
No problems yet.

Tom

#3 Dan203 Aug 24, 2010 12:30 AM

OK glad to hear it's normal. I didn't want ti to like burst into flames on me or something. :)

Dan

#4 Timewerx Aug 24, 2010 02:47 AM

Try this mod if applicable :)

http://helifreak.com/showpost.php?p=...2&postcount=40

That is for the 10A L3 ESC (stock 4G6)

#5 Tom Z Aug 24, 2010 06:28 AM

Quote:

Originally Posted by Dan203 (Post 15869816)
OK glad to hear it's normal. I didn't want ti to like burst into flames on me or something. :)

Dan


Also mount the 6 FET's up so they run cooler. Mounting them down
will reduce the air getting to them and they will run hotter.

A heat sink would be good to keep it cooler like Timewerx said.
I want to try it. A small piece of aluminum with thermal tape attached
to the 6 FET's should work great.

Tom


All times are GMT -5. The time now is 06:37 AM.