RC Groups

RC Groups
    CAD/CAM
        Mini-HowTo Sketchup to tiled pdf plans

#1 Kwok_Yu Feb 28, 2010 04:34 AM

Sketchup to tiled pdf plans
 
11 Attachment(s)
It's always been hard to make tile pdfs in Sketchup. The latest idea which worked ok, was to use cutepdf as a print driver and print directly to tiled pdf. But you had to fiddle with it and there were alot of problems with blank pages and large un-needed boarder area. I think, I know the reason of these problems and the answer is don't check "Use model extents" as you will see in the pictures. Also, there are new programs now available to help us. A few days ago I saw this post, by ajreynolds : http://www.rcgroups.com/forums/showp...&postcount=617 He found some free pdf programs at: http://www.noliturbare.com/ and explained how he used the cropper and tiler. They also have a program to rotate and resize the pdf. So the new method would work like this: 1) Print out a single sheet pdf, of the entire plans using cutepdf as your sketchup print driver 2) If you didn't set it up right, then use the cropper program to get rid of the unwanted perimeter space. The tile I did below, was actually the orginal pdf from sketchup, so you can do it without cropping. But now you don't have to worry, if you can't get the pdf out perfectly. 3) Use the tile program, to generate the tiled pdf. It also gives the option of putting placement marks and an overview sheet (last pic).

update: The cropper program doesn't seem to work. It doesn't take much off, even if there is alot of blank space around the plans. So unless, I am doing something wrong, you still got to get your cropping done when you print out from sketchup.

addition: I didn't add this info originally, because I thought the cropper program would take care of it. But I've done another test and it still doesn't work for me (see post#4). So here is how I set the cropping in sketchup:
Quote:

1) Go into "print preview". Set scale to 1:1. You may have to check and uncheck the "Use model extents" to get this done and the see the dimension of the full sheet to the left. But most likely, you will want "Use model extents" unchecked when done. Otherwise, I pretty sure it will add in that 10" border everyone is talking about. You can just check the sheet dimension, on the left, and see how it changes when you check that box.

2) Then pick cutepdf as the printer. Go into cutepdf's advanced properties and set dpi to 300 (I haven't figured out how to save this setting, and had to do it every time). And most important, set a custom page size to what was shown in the provious step. Its got to be bigger, so use you judgment to round up a whole or half inch.

3) If it show up right in the "final print preview" screen, then you are all set. Sometimes it seems there is a slight bug in the "final print preview" screen and it shows up as two pages. Possibly it is because, I was experimenting and setting the sheet size extremely close to the actual plan size. So it may be a rare occurrence. But if this happens, you can try just switching to the second page and possible it will change to only 1 sheet. Or exit out of preview and try the "print preview" again. Your setting shouldn't have changed and you just need to hit OK, to see the "final print preview" screen again.

*****Note: I've assumed you are familiar with the old way of tiling pdf. The above instructions are for making a single sheet and then tiling with another program. So if you are not doing that and want to tile straight to the pdf driver, then you don't need to do step 2 (set a custom page size). Also, if you are new and don't know; sketchup must be set to "parallel projection" mode in the camera menu. Otherwise, you won't be able to adjust the scale in the print menu.
addition2:
Derfy, in post#14 looks like came up with the reason for the cropping problems, I have been having. That is the sketchup print method of output, is creating a raster image. So the cropping programs will only crop down to this minimum size. As an experiment, I tried exporting 2d graphics to pdf (not print) in sketchup pro (see post#15) and zooming in looks like vector format. And the result was all the white space was completely cropped away.

*** Cropping Problem Solved ***:
Ok, big news! If you check the right bottom box in the print menu, labeled "Use high accuracy HLR", sketchup will print out pdf in vector. Not only does this solve pdfs not cropping problem, but also your plans will now be in much higher quality and you can zoom in as far as you like and quality doesn't change. Not only that, you pdf file size will be much smaller. I just did a test with the surfer dude plans and the vector pdf was ~3.5X smaller (170KB vs 614KB).

Credit goes to Derfy and my good friend in LA, who independently came up with the solution. And to philba, who keep my head scratching to formula a question which needed an answer. Good work guys! :D


-Kwok

#2 Kokopeli Feb 28, 2010 08:00 AM

Thanks, Kwok.
Is there a link to FLYING SURFER DUDE?

Walt
EDIT:
Never mind - found it:
http://www.rcgroups.com/forums/showt...ht=surfer+dude

#3 VeeOneRotate Feb 28, 2010 10:45 AM

Thanks Kwok_Yu!
I just got it all working, absolutely fantastic!

#4 philba Feb 28, 2010 02:52 PM

Yes, kudos to Andy for the original find. They work quite well, easy to obtain and a great price. Cropper works for me, by the way. One thing that would be nice is if the tools all know your directory. I think the cropper defaults to the directory where the program lives. I have a bunch of suggestion for him but it's a wonderful start!

The tiler is particularly nice. Especially with the overlap and cut marks. The summary page option is great, too. I'd like to see the ability to move the image around within the "cropping frame" to minimize the number of pages something big needs but that's a minor nit.

by the way, to print to a single page using cutepdf, I had to go into advanced and select a huge page size. It seems like to should be an option to autosize the page. Am I missing something obvious here?

edit: I think the cropper problem occurs if you don't check the "fixed folder" box.

#5 Kwok_Yu Feb 28, 2010 03:55 PM

2 Attachment(s)
Quote:

Originally Posted by philba (Post 14471392)
.....

by the way, to print to a single page using cutepdf, I had to go into advanced and select a huge page size. It seems like to should be an option to autosize the page. Am I missing something obvious here?

edit: I think the cropper problem occurs if you don't check the "fixed folder" box.

I've added some more info on the 1st post, as to how I set the cropping in sketchup. I don't know of an autosize. Would be nice, if there was one.

The "fix folder" just sets the output path so it goes to the same folder each time. I did another test and it definitely not working for me. I drew a single tiny box and zoomed out to 35" x 35". As you can see the cropper program did almost nothing. It reduced the sheet size only to 34.8" x 34.4".

#6 philba Feb 28, 2010 09:02 PM

3 Attachment(s)
I dunno, I tried something similar. Small boxes and it cropped them ok. Running su 7.1, win7/64

#7 Kwok_Yu Feb 28, 2010 09:39 PM

Interesting. Thanks for posting that. At least I know it actually works and will keep trying. I'm using SU v7.1 also, but on winxp. Ghostscript should be the latest version as I just installed it and .net v2. 3DMON said he was having trouble with the cropper, too.

-Kwok

#8 philba Feb 28, 2010 10:04 PM

I wonder if the .net version is the problem. I installed ghost script today and took the latest one, too, so we should match there.

#9 Kwok_Yu Feb 28, 2010 11:50 PM

1 Attachment(s)
philba,

I download another program called soPdf and still can't crop. As far as I know it doesn't use any external programs. So I'm starting to wonder if it's my pdf file. Could you upload you pdf file, so I can try it? And here is mine, if you don't mine trying to see if it will crop for you. -Kwok

#10 Kwok_Yu Mar 01, 2010 01:29 AM

3 Attachment(s)
Ok, I figured it out! :cool: You can't crop any smaller than what you had showing on the sketchup screen. So even though you zoom out and it looks like alot of nothing, sketchup is putting something there. So that pdf I posted above, you can't crop. But this one you can. But still, only like I had it on the screen with the white space on the right and left side. I also verified this with another program called soPdf. I've posted it below, if anyone wants it. I've repackaged it to save you time. And it doesn't need the ghostscript or .net.

#11 philba Mar 01, 2010 10:56 AM

glad you figured it out. I'm not sure I understand, though. I think you are saying that if you show lots of space in sketchup and print with that, it places something invisible in the print out (i.e. the pdf). This wasn't my experience. I just tried the following test:
  • make a 1 mm x 1 mm box
  • zoom way out in SU
  • print to cutepdf. page size 36x60, portrait, 1200 dpi (you can't even see the box in the pfd)
  • cropped with the same setting as I posted last night
Results were that it copped to the 1x1mm box no problem. I'm glad you have a solution, though. Sometimes SU does some odd things that don't make sense - sort of a ghost in the machine.

Running without .net and ghostscript is an advantage though I need them for other things so it's a wash for me.

#12 Kwok_Yu Mar 01, 2010 03:35 PM

Yes, you understand me correctly. But it's working for you, so still something more for me to figure out. Could you test if you can crop that pdf in post#9?

-Kwok

#13 philba Mar 01, 2010 03:47 PM

You aren't crazy! I got the same result as you did. No cropping. I extracted the image from the PDF to see if there was something there. Nothing was obvious. I thought maybe the background color wasn't exactly white but it looked ok to me. It's definitely something that sketchup is doing.

edit: I though maybe it was the narrow border on the box you drew but even a box printed with no border doesn't cause the problem. I tried all permutations of window/style/edit and wasn't able to produce a pdf that wouldn't crop.

#14 Derfy Mar 02, 2010 12:01 PM

Well, I must admit that I had the exact same problem as everyone else when it came to cropping a PDF produced in Sketchup and printed with CutePDF.
It took many hours of head scratching to realise what was going on and it turns out that the culprit is CutePDF, not Govert's proggie. :confused:

The reason why it doesn't crop properly is clearly stated on Govert's page for his PDF Cropper:

Quote:

Originally Posted by Govert
Note that it does not crop the white space from raster images

and what type of PDF does CutePDF produce? - a raster image.

This results in you not being able to crop anything less than the Sketchup viewing window, even though you select a page size that is larger than the window when printing.

Oh well, back to the drawing board (yet again). :D

:cool:

#15 Kwok_Yu Mar 02, 2010 06:06 PM

1 Attachment(s)
Quote:

Originally Posted by Derfy (Post 14487781)
Well, I must admit that I had the exact same problem as everyone else when it came to cropping a PDF produced in Sketchup and printed with CutePDF.
It took many hours of head scratching to realise what was going on and it turns out that the culprit is CutePDF, not Govert's proggie. :confused:

The reason why it doesn't crop properly is clearly stated on Govert's page for his PDF Cropper:



and what type of PDF does CutePDF produce? - a raster image.

This results in you not being able to crop anything less than the Sketchup viewing window, even though you select a page size that is larger than the window when printing.

Oh well, back to the drawing board (yet again). :D

:cool:

Derfy, thanks for that! That certainly the same thing I am seeing, but not understanding why until you explained it. I decided to see what the sketchup pro would do. This is the export feature, not print. I zoomed way in (diagonal line) and no change, so looks like vector. And I must say, talk about no white space. Govert's cropper cropped it down to nothing! :)

-Kwok


All times are GMT -5. The time now is 09:45 PM.