New Products Flash Sale
yosemitez's blog View Details
Posted by yosemitez | Nov 25, 2015 @ 03:11 PM | 514 Views
GoPro4 filter and lens hood

Filter from Snake River Prototype, available as UV or Polarized,

And a sun shade
Posted by yosemitez | Nov 14, 2015 @ 01:56 PM | 1,868 Views
qav400 - naze32 - 4s 3600mah - rotorgeeks 30a escs -120kv motors - betaflight - oneshot - dampening light - gopro4 4k video

post crash analysis:
its hard to really say what caused this failure. i do remember the screen going to snow and i may have cut the throttle out of habit. it all happened so fast as it was in a 50mph dive and the next second it was on the beach.

upon post power up all systems worked perfect except esc1 which powers the naze32 was not working. the others are opto. upon further power ups esc1 reactivated and works normal, have had this problem a couple of times but if i reboot it comes back. this qav400 pdb could also be suspect as it had reverse polarity burn out on battery 1 connector. i moved the battery connection to battery 2 and and continuity showed good on all connections.

the battery was ejected so now way to tell if that became disconnected but highly unlikely, xt60 connectors. the rx wire was disconnected, probably caused by crash as it is zip tied in several spots to prevent disconnect. the vtx was loose but not out and still had signal. antenna came apart at the 90 degree to the vtx, could have come off in flight? but is secured by rubber bands.

it could have lost power from esc1 to the naze32 and gone into failsafe, 0 throttle, but the vtx system is powered by a good quality bec off the pdb. why did the video signal go out?

so who knows? really no damage except one broken landing gear, really amazing considering the impact.

i am going to tear it all down and move the esc's to a good pdb. but i first i must go fly!
QAV400 - NAZE32 bad crash, total power loss? (3 min 33 sec)

Posted by yosemitez | Oct 23, 2015 @ 06:28 PM | 1,361 Views
so i messed up my solder job on my Seriously Dodo Flight Controller on the motor connectors as to where motor 1 and motor 4 do not work as they are getting no signal.

in cleanflight you can reassign motors to different channels in cli.

cleanflight 1.10 and betaflight 10/15 release fw, note cf 1.10 uses mmix instead of cmix

# mmix ////will show you current motor setup, probably quadx, take note of settings to reassign them.

# mmix reset ///clears the current settings

# mixer custom ///enters you into the programming

now to enter motors, you have to start at 0 and go in order.

since the pad on motor one was messed up i entered this which disables that channel, note that 0 is really motor 1
#mmix 0 1 0 0 0 0

this reassigns motor 1 to channel 2 on the dodo
mmix 1 1 -1 1 -1

this reassigns motor 2 to channel 3 on the dodo
mmix 2 1 -1 -1 1

enter mmix and it should now look like this
# mmix
Motor Thr Roll Pitch Yaw
#0: 1.000 0.000 0.000 0.000
#1: 1.000 -1.000 1.000 -1.000
#2: 1.000 -1.000 -1.000 1.000

my 4 and 5 pads were messed up so i entered this
mmix 3 1 0 0 0 0
mmix 4 1 0 0 0 0

and now have this
Motor Thr Roll Pitch Yaw
#0: 1.000 0.000 0.000 0.000
#1: 1.000 -1.000 1.000 -1.000
#2: 1.000 -1.000 -1.000 1.000
#3: 1.000 0.000 0.000 0.000
#4: 1.000 0.000 0.000 0.000

now to add motor 3 to channel 6
mmix 5 1 1 1 1

now to add motor 4 to channel 7
mmix 6 1 1 -1 -1

now looks like this
# mmix
Motor Thr Roll Pitch Yaw
#0: 1.000 0.000 0.000 0.000
#1: 1.000 -1.000 -1.000 -1.000
#2: 1.000 -1.000 -1.000 1.000
#3: 1.000 0.000 0.000 0.000
#4: 1.000 0.000 0.000 0.000
#5: 1.000 1.000 1.000 1.000
#6: 1.000 1.000 -1.000 -1.000

image shows motor tab with motors powered up and motors 2,3,6,7 are spinning up! #2 spins up motor 1, #3 spins up motor 2, etc. so it seems to have worked.

just need to set motor direction and then test
Posted by yosemitez | Oct 15, 2015 @ 07:43 PM | 1,454 Views
QAV400 - Naze32 - Betaflight - Oneshot Damping Light

Got some new rotorgeeks 30a blheli esc's and will be putting these in and updating the naze32 to betaflight and trying out luxfloat.
Final results, amazing
Qav400 - Naze32 - Oneshot - BlHeli - Damping Light - LuxFloat- 1st flights (2 min 58 sec)

here are the rotorgeeks 30a blheli esc's installed and the power wire for the pdb to battery xt60. this is how i now have it on 3 other qav400's and one has over 500 flights and the connector is still going strong. this keeps it neatly out of the way and it is so easy to connect with the battery wires facing backwards.

nice video on using adjustments to tune your quad with cleanflight
PID Tuning video 2 (8 min 49 sec)
...Continue Reading
Posted by yosemitez | Sep 26, 2015 @ 11:08 PM | 2,053 Views
i wanted to flash my rcmanchild 30a esc's from 2013 with the latest simonk or blheli to try out the active braking.

after digging around and writing rcmanchild he uses the simonk and wrote back "Any nfet file. I use HK 30a ubec." his esc's look very similar to the hk 30a.

i am using the afro linker which uses the same drivers, a com port, used to talk to the naze32 with windows, i am using win7.

i first tried kkmulicopter flash tool 0.77 with these settings
afro usb programming tool, com4, atmega 8-based brusheless esc, bs n-fet, bs n-fet v2015-04-19 by simonk. see attached image
hook up to usb, attach battery, flash. it said the flash was successful.

second flash is to load up blheli, start up blhlei, these are atmel bootloader afro usb linker, com4, connect, plug in battery, select hk_ubec_30a multi, flash. flash was successful. you will know you are connected by the little white rectangle down and left of the "read setup" button. the top one will flash every second.

there is a great tutorial here for blheli

video showing comparison between simonk and blheli with damping light enabled
Comparison of SimonK to BlHeli on RCManchild ESC's (0 min 17 sec)

Posted by yosemitez | Aug 31, 2015 @ 10:27 PM | 1,918 Views
Lawmate R1200-Plus and TM-121 VTX, new purchase from hobbywireless 8/25/15

i ordered the lawmate rx1200-plus but received the rx-1260, the invoice says rx1200-plus. hw support has told me the only difference is that the rx-1260 has channel 1258 added, which i have confirmed. i just want to know if this rx-1260 also has "high sensitivity" as advertised and the same specs as the rx1200-plus or if there are any other differences.

i have asked around and there is no real info on this rx-1260 except that it is sold at hobby king for $34 (minus ch 1258) whereas this cost me $59 from hw the channel selection does seem to match the rx1200-plus as you have you this

Group A
CH1. 1200.CH2. 1240
CH3. 1258
Ch4. 1280

R1200-Plus - 1.2 /1.3 GHz Standard Receiver (includes 1258 MHz) The new R1200-
Plus receiver has the 1258 MHz frequency added, providing an additional legal channel in US and many other countries. It has eight (8) user selectable PLL lock channels, very stable and solid video reception.
- Eight (8) RF channels
- Phase Lock Loop (PLL) stability for drift-free operation
- Composite video, supports NTSC and PAL standards.
- FM-FM modulation.
- 5.5MHz audio sub-carrier (mono).
- DIP switch channel selection.
- RF sensitivity -85dBm (typical).
- Supply current Vcc 240mA (maximum).
- Video input voltage 75-ohm impedance 1Vp-p.
- Audio input voltage 10k ohm impedance 1Vp-p.
- Power-On LED indicator.
- Operating voltage: Vcc, 10.5V (minimum), 12V (typical), 13V (maximum).

TXV1012-Plus Dual Power 500/1000mW 1.2/1.3 GHz "Plug & Play" Transmitter
says TM-121 on the vtx
- High quality microphone
- Audio volume control
- High quality 12v voltage regulator for camera and transmitter (no heat and noise free)
- Reverse-Polarity Protection (avoids damage if you plug the battery pack inverted)
- Power output for 12 volt cameras.
- Molex connector with safety latch (prevents connection to come loose while in use)
- Power LED (helps to identify bad power connection, reminds you to disconnect power when it’s not in use)
Posted by yosemitez | Aug 14, 2015 @ 08:40 PM | 1,777 Views
Decided to set the Osdoge and Naze32 up like i saw at they have some great photos and tutorials and sell the 2 ready to go.

first off test both boards while hooking up to USB and loading the latest firmware. There are many how to's on how to flash the Naze32 as it is in the Baseflight chrome app. It was hard to find how to flash the Osdoge but it was in the website under install guide
how to flash the osdoge with the latest fw:
1. Download and install Arduino software for your system
2. Download and unzip latest MWOSD
b. There’s 2 folders it creates. One for the source package (MW_OSD) and one for the configurator (MW_OSD_GUI)
3. Connect the OSDoge to your computer via its USB port.
4. Launch Arduino software
a. Go to File > Open and browse to open the file named “MW_OSD.ino” from the source package folder.
b. Go to Tools > Board > Select “Arduino Pro or Pro Mini”
c. Go to Tools > Processor > Select “ATmega328(5V,16Mhz)”
d. Go to Tools > Ports > Select the COM port for your OSDoge
e. From the menu, click on the Upload icon to flash the OSDoge

After flashing the OSDoge grab the latest MWOSD gui, found at i am running win7 64 bit and could only get the 32bit version to...Continue Reading
Posted by yosemitez | May 01, 2015 @ 07:55 PM | 2,212 Views
I have 2 identical QAV400's except for the FC, one has vector and the other Naze32. I have really been liking the Naze32 as it is so responsive and smooth. When flying manual and you set it on a course with no more stick inputs it is like a arrow, flies straight and true until the next command.

The vector flies great and was very crisp but it would never fly true, it always had a slight wavering when there were no stick commands.

So i really played around with the PID's and ended up with this. seems to fly very crisp and when there is no input it follows the line very true.

QAV400 - Eagle Tree Vector - PID adjustment (4 min 59 sec)

Posted by yosemitez | Apr 13, 2015 @ 05:10 PM | 2,414 Views
Vector GPS RFI Interference Shielding

Was having problems with the vector loiter so tried shielding the gps with copper foil and it really helped. went one step further and cut open the top son the gps had a cleaner view of the sky.

Apparently gps signals are so weak that any rfi from your vtx or gopro will have some effect on the gps
here is the vector after the fix
Eagle Tree Vector Loiter test 4/11/15 PERFECT! (1 min 50 sec)

Posted by yosemitez | Feb 12, 2015 @ 01:09 PM | 2,717 Views
Trying a little duct tape to make it more aerodynamic.
QAV400 - Naze32 - 1200kv with 4s (2 min 6 sec)

Posted by yosemitez | Feb 02, 2015 @ 04:50 PM | 3,029 Views
Bare Bones Build
NTM 2826 1200 KV
400mw VTX
Posted by yosemitez | Dec 07, 2014 @ 06:55 PM | 3,997 Views
UPDATE 2/2/15
This was kinda fun and sure you can fit in some tight places and go through some playground equipment but it just feels and flies like a little toy, nothing like the QAV400. Sold it and built a new bare bones QAV400 for power!

After reading so much about the mini quad craze i decided to give it a try. Will be building a Backout Mini H Quad with NAZE32 Acro - EZUHF - Futaba 8FG. There are tons of videos and how to's on most every aspect of this so i am just making notes on parts of the build where i could not find info or had to really dig to get a answer. These are notes to self on how I got this setup working.

First wanted to update FW on the Naze and it seemed simple enough with some programs but then i saw a video where they do it from inside Baseflight(Chrome app version). I already had BF up and running so i go in and look for where it says to update the FW like i saw, cant find it anywhere? Reason why is that you have to have the board disconnected! for the FW update screen to be visible. I had BF set up to auto connect and that is why i couldnt find it. Once found, update of FW was easy.

set align_board_yaw = 90 to rotae board 90 degrees so usb port sticks out side

EZUHF 8 channel Lite, make sure latest FW 1.50 on this one, 8 channel, PPM Muxed. see images 2 and 3

Wire setup between Naze and EZUHF with 6 volt battery providing power to EZUHF. Image 4

EZUHF is...Continue Reading
Posted by yosemitez | Nov 14, 2014 @ 01:06 PM | 3,893 Views
QAV400, 6,300' distance flight
Posted by yosemitez | Oct 14, 2014 @ 08:42 PM | 6,305 Views
GoPro Hero4 Black vs GoPro Hero3 Black

Just got the new GoPro Hero4 Black and the 4K to me looks much sharper, true colors and just plain crisp 3D looking. Now this could all be just me excitied over a new camera so I decided to do a side by side comparison.

I strapped both cameras to my QAV400 and did some filming while hovering around the yard. I shot stills and 2.7k 30fps. Then I tried 4K 30fps on the GoPro Hero4 Black and the GoPro Hero3 Black at 15 fps, on this I will do some frame grabs for comparison.

Still Image Comparison, these are unedited straight from the camera.
The GoPro Hero3 Black image looks sharper but that is because it is doing in camera sharpening and color correction. GoPro Hero4 Black image has protune(GP3 has no still image protune) so i have the protune on with sharpening on low, 400 iso and -5 exposure compensation (to not blow out highlights). I was having a real hard time getting true sky colors with the GP3, it was always washed out in the highlights and a wierd gaudy color. The GoPro Hero4 Black image looks much better as far as colors go and i am sure some sharpening in PS would help.

Photos 4 and 5 are still images zoomed in 200%. The GoPro Hero4 Black is not as sharp but the colors are much more accurate and the white wispy clouds have tons more detail.

2.7K Video Comparison- Frame Grabs
Here are frame grabs from some 2.7K video. The The GoPro Hero4 Black looks much better, sharper and again the colors are more true with sky not a...Continue Reading
Posted by yosemitez | Oct 03, 2014 @ 06:56 PM | 5,676 Views
I have now had the Eagle Tree Vector installed in my QAV400 since July 2014. I continue to be impressed with how it handles in full manual flight (i have never used loiter or 2d). This coupled with the customizable OSD makes for fun flying!

I had not flown my other QAV400 with a KK2.1 since getting the Vector so I decided to install a Vector in it and then add on a gimbal.
Photo 1- Pigtail PSU soldered to PDB

Photo 1A- On this build i decided to go with the Pigtail PSU as I could solder it right into the PDB and eliminate a lot of connectors. On my first build I have the XT60 PSU version and after using it a few times it became very evident that it would not stand up to constant use so I added a small pigtail. That added 2 more connectors for a total of 3 XT60's. This new version has just 1 XT60.

Photo 1B- XT60 PSU version on my first build showing all the connectors. Over 300 flights on this setup and still feels solid. This set up makes it easy to plug in and unplug the battery as you hold the XT60 against the frame,

Photo 2- Next was the power to the EZUH. I built a short JST connector wire and this is connected to the Vector 5v tap. You will also see in this photo the Receiver Connection Harness. Since I am using Serial PPM i removed all the extra wires including the red power wire.

Photo 3- shows the wiring and how i had to move the Vector forward to maintain the CG on the QAV400. Also notice how the Vid tx and cam connectors are...Continue Reading
Posted by yosemitez | Aug 22, 2014 @ 05:52 PM | 4,244 Views
Eagle Tree Vector - QAV400 - 1.2 mile run
Lee Vining Creek, 8/19/14
Elevation 9,500'
Eagle Tree Vector - QAV400 - 1.2 mile run (5 min 27 sec)

Posted by yosemitez | Jul 26, 2014 @ 04:38 PM | 6,453 Views
Eagle Tree Vector installed in a QAV400, Advanced Gain Settings

After thousands of flights with the trusty KK2 i am now trying the Vector in my QAV400. I only fly in full manual (3D vector speak).

As the KK2 the Vector is totally configurable in the field but is done through the OSD on the monitor. There are so many options that it is very overwhelming at first coming from the simple world of KK2.

The Vector is mounted a bit forward of it s recommended CoG so that I can get the battery far enough forward to maintain the QAV400 CoG, it seems to have no effect on the flight characteristics.

After 20 flights I am finally getting it dialed in through the Advanced Gain settings as to where it feels as crisp and responsive as the KK2.1.5

It seems very smooth and responds quick to stick commands. It does not have the jitters / oscillations when dropping down in a hover that is found on the KK2, very smooth dropping down flat

These are the current settings as of 7/26/14