Espritmodel.com Telemetry Radio
boaterguy's blog
Posted by boaterguy | Nov 06, 2013 @ 05:14 PM | 4,717 Views
I got my hands on a really nice power supply. I now have a server supply (12V 41A) and this one which does a few amps at 3v3, 10A at 5V, 19A at 12V, and 0.1A at -12V.
So at first I just converted it from ATX to a standard bench supply with 5.5mm connectors on each end and started making adapters, one for an RX to be plugged into 5V, and a deans plug that I can use for testing so I don't always have to find a charged battery just to power something up. I also added 5.5mm connectors on my charger so I could power them off of this and I plan on re purposing the server supply (suggestions?).
After that, I realized it was taking up the remaining 1/25th of my workbench that wasn't already covered in stuff, so I mounted it underneath the table and had the connectors on a little dev-board connected to all of the wires. Once again, a pain. Now all the wires have to reach around the edge, and to the connectors underneath. So I pulled the wires on the PCB and hooked them up directly to the connectors with some more wires to add length. I then drilled holes in my workbench (an old card table) for the LED (power on), and one for each terminal. The holes were 1/4" which worked out to less than 5.5mm so I had to hammer them in for a nice, snug fit. The downside to this was that I had to make my final solders under the table, not as fun as it sounds.
This is how it looks now. I can't figure out how to mount the switch since I can't really easily cut a rectangle in 1/2" particle board, so any suggestions are welcome there.